iPhone On-screen keyboard disappeared

Discussion in 'Jailbreaks and iOS Hacks' started by Qaanol, Feb 25, 2013.

  1. Qaanol macrumors 6502a

    Jun 21, 2010
    Today, suddenly, my standard English keyboard started appearing entirely black. The keys still work, I just cannot see where they are. It worked fine yesterday. In fact, I’m pretty sure it worked fine this morning.

    I have an iPhone 4S running iOS 6.1.2. I jailbroke it with evasi0n 1.4.

    I have the following keyboard tweaks installed: SwipeShiftCaret, SwipeSelection, ShowCase, and DeleteWord. I have had them for a long time, and they have worked flawlessly. Indeed, thanks to ShowCase, the lowercase keyboard shows up properly.

    Today I updated to evasi0n 1.5 through Cydia (package version 0.4-1). I also updated DisableNC+, symbolicate, and Universal Video Downloader to their current versions.

    I installed AppInfo and used it to export lists of my tweaks and apps to my email.

    I installed ActionMenu, and it was in the process of testing out that tweak that I discovered the standard keyboard was appearing all black. So I uninstalled ActionMenu, but the problem was still there.

    I then reinstalled SwipeShiftCaret, SwipeSelection, ShowCase, and DeleteWord. The problem was still there.

    Also at that time I noticed the rich text options were no longer in the action menu. I opened Flex and found that none of the patches I had installed prior to updating to 6.1.2 were still there. So I downloaded a number of Flex patches, including Rich Text Editing (iOS 6) for Notes.

    Still, the regular capital-letter standard English on-screen keyboard shows all the letters as a solid black area. The Shift, Delete, 123, Language, Space, and Return keys all show up properly.

    What can I do to get the standard keyboard to appear properly again? I’m hoping to avoid restoring in iTunes because that is time-consuming, so if there is something else I can do, perhaps through Cydia, SSH, or iFile, that would be preferable.

    Attached Files:

  2. TM WAZZA macrumors 68000

    Sep 18, 2010
    Hamilton, New Zealand
    I had this problem. I found the culprit was ShowCase. Uninstall that and see what happens.
  3. Qaanol thread starter macrumors 6502a

    Jun 21, 2010
    Thank you kindly, uninstalling ShowCase did indeed resolve the issue for me.

    I then reinstalled ShowCase after removing it, and when I went to edit a note, the Notes app crashed and the black keyboard reappeared.

    So I removed ShowCase again.

    Then, being doggedly persistent, I installed ShowCase once more. This time I opened Messages and confirmed both majuscule and minuscule keyboards worked. I did the same in Safari, and then the same in Facebook. Finally, I opened Notes, and waited for it to fully launch, then tapped to edit a note.

    And what do you know, the keyboard works properly with ShowCase installed, just like it used to. Very strange.

    Thanks again for the assistance.

Share This Page