One contact default responses in German

Discussion in 'Apple Watch' started by Neutral Milk, Jul 8, 2015.

  1. Neutral Milk macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #1
    The title says it all. For some bizarre reason when I reply to one of my contacts through my watch all the default replies are in German. This doesn't happen for any other contacts that I've looked at.

    This was funny at first but is now annoying.

    I can't find any settings to change. Any thoughts?
     
  2. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #2
    Sehr interessant! Have you tried deleting the contact in iPhone Contacts, doing a hard reset on both devices and then adding the contact again?
     
  3. Neutral Milk thread starter macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #3
    No. Ugh. I imagine that will probably work, but I'd love an easier solution.

    More than anything I'm curious about how that might happen. Software glitch or user error? Accidental setting change?

    Deleting and Resetting is such a last resort "I give up on figuring this out" move. I appreciate the advice, and if nothing else I'll do that, but I'm hopeful someone may have an idea of what happened so I can learn from it.

    I'll contact Apple when I get home too and see what they say.
     
  4. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #4
    Deleting and then adding the contact again is pretty straightforward. Sorry, I'm suggesting a reset - press both buttons on each device until Apple logo appears - not wiping and reinstalling software. Apologies if my post was unclear.
     
  5. Neutral Milk thread starter macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #5
    No, no, no, you were clear! And you gave solid advice! I guess I'm saying that's too easy more than that's too difficult. I'm fairly certain your advice will work, but again I'm more interested in finding out "why". If I fix it with your method I won't be able to play around with non reset solutions.
     
  6. nicho macrumors 68000

    Joined:
    Feb 15, 2008
    #6
    do you have the german keyboard as one of your keyboards in the phone? if so, this is normal behaviour - go to that contact and see which keyboard is active in that chat. the default responses mirror the language of the keyboard in that contact's conversation.

    if you don't, its a weird bug.
     
  7. Neutral Milk thread starter macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #7
    German is one of my keyboards, but if I go to my chat with her on the phone it is set to default English. Predictive text is also all English on the phone with this contact.
     
  8. Neutral Milk thread starter macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #8
    Contacted Apple support. They were clueless. Recommended unpairing and repairing assuming it's a glitch in how the info about that contact transferred over (reading the contact as being located in Germany).

    Haven't done it yet. Deleted the contact and did a hard reset on the watch but that didn't fix it. After the hard reset the texts still show up on my watch with her phone number rather than name (obviously) and when I hit reply on the phone number still in German.

    I'll unpair at some point.
     
  9. nicho macrumors 68000

    Joined:
    Feb 15, 2008
    #9
    The message conversation would still be in German (or think it is) so thats not going to change, contact or not.

    I tested this dictating responses to my wife and it works, if you try the following it might shake the watch into getting the right language. When I set her conversation to chinese, and dictate some chinese, it gives me a message in chinese characters (there are no default responses in chinese, for some reason). if i say english it will approximate it into chinese sounds. when I change it back to english UK it will recognise the english words (and start to give me default responses as well as my own) - so obviously this behaviour is working properly (for me)

    I would suggest following my steps above. changing it to a different language and then back to English may be what it need to fix it. if you do want to try it - add the chinese (simplified, pinyin) keyboard, set it to the chinese keyboard for that conversation and then dictate a reply to them on the watch ("ni hao", pronounced kind of like "knee how". if it comes up with 你好 on screen you know the watch is now following the keyboard you chose) if it works, you should be able to switch it back to english and it should work. if not, i guess the only option left is to unpair, but I'm hoping this works for you.

    :)
     
  10. Neutral Milk thread starter macrumors regular

    Neutral Milk

    Joined:
    Apr 28, 2015
    #10
    It worked! Thanks nicho!

    I tweaked what you said a little, but using your general suggestions. I sent her a text on my phone through the Spanish language keyboard (I had tried the english earlier on and had sent a few texts but it hadn't affected the watch). After sending a text in Spanish through the phone my watch had default options in Spanish. Then I changed the keyboard on my phone to English and sent a text, when I went to my watch the replies were finally in English.

    Some weird glitch. I may have sent her a message in German at some point and it got stuck that way.
     
  11. Hpfeffer macrumors member

    Joined:
    Sep 17, 2014
    #11
    You can choose a language by force touch on the microphone...
     
  12. SethBoy macrumors regular

    Joined:
    Jun 23, 2007
    #12
    Wow, great tip. Not sure if it’s a WatchOS 2 thing though.
     
  13. nicho macrumors 68000

    Joined:
    Feb 15, 2008
    #13
    i believe it is.
     

Share This Page