One I just can't work out - USB port madness - Any ideas what this could be?

Discussion in 'Mac Pro' started by rossagrant, Oct 31, 2012.

  1. rossagrant macrumors member

    Joined:
    Mar 3, 2009
    #1
    Hi guys,

    This is just insane and I have no idea what could be the issue.

    It's not a huge deal but it is annoying the hell out of me what it could be.

    I have been using a USB mic with Skype for the last year to record podcasts for my site.

    NOTHING hardware wise has changed at all (just the occasional update to Skype).

    On a test call this morning with a new podcast guest I noticed that I was getting a lot of interference in my headphones and the guest said that I kept echoing.

    I tried to connect again, restarted Skype, all to no avail.

    Now I thought I'll try and change the USB port, and yep the mic worked no problem.

    Now this is where it gets weird.

    The mic has always been plugged into the same port, and has always worked until today.

    The usual port for the mic is port 1 on the back of my 27' cinema display, which is powered from the usb cable plugging into the mac pro to power the display.

    So port 1 doesn't work for the mic.

    Using ports 2 & 3 on the back of the cinema display WORKS.

    Now if I change the usb port that the ACTUAL CABLE FROM THE CINEMA DISPLAY to the Mac Pro goes into, then port 1 on the back of the cinema display works with the mic again.

    Therefore I thought it might be a problem with the USB port on the back of the mac pro?

    To top it all off, if I decide to change the output of the mic to 48mhz from 44mhz then it works in ALL combinations regardless of where it plugs into on the back of the display and regardless of where the display plugs into on the Mac Pro.

    All other peripherals such as iPhones and printers work with port 1 on the back of the display, just not the microphone when it is plugged into PORT 1 ON THE DISPLAY and when the display is plugged into PORT 1 on the Mac Pro.

    I hope you kind of understand that, I know it's ridiculous.

    Basically, I'm asking if there can be any issues with USB ports that can leave them semi working with mics, but still give you inteference?

    Would changing the frequency of the mic alter the amount of power the USB port needs and could that be fixing the issue.

    Could something as simple as dust build up and cause this kind of interference?

    It's just bizarre.

    Thanks for your patience if you just read that, it couldn't have been easy!

    :)
     
  2. tamvly macrumors 6502a

    tamvly

    Joined:
    Nov 11, 2007
    #2
    Have you considered the possibility that your mic is giving up the ghost in some bizarre way?
     
  3. rossagrant thread starter macrumors member

    Joined:
    Mar 3, 2009
    #3
    Hey Tam,

    The mic works flawlessly when plugged into any of the USB ports on the actual Mac Pro, it just has the problem when plugged into the first port on the back of the Cinema Display ONLY when the Cinema Display is using the first USB port on the back of the Mac Pro.

    All other combos work.

    I just thought it was completely and utterly bizarre!

    Have reset SMC and PRAM and still get the issue!

    Gonna leave it all unplugged overnight and revisit in the morning!

    Thanks for the reply!
     

Share This Page