one more HDD reformating Q

Discussion in 'Mac Basics and Help' started by bordenkecher, May 16, 2006.

  1. bordenkecher macrumors member

    Mar 24, 2006
    ive got this 80g WD HDD and it used to be formated nstf or whatever the PC standard format is. ive tried to use disk utility to erase and reformat in in MAC Osx Extended, but after a long time of trying to partition the HDD it'll create a little sub name for the drive: disk2s10 which is not even what i told it to name the drive as.

    when i go to verify and repair the disk i get the error of death is seems for me "Error: the underlying task reported failure on exit" and it'll say volume can not be repaired because o an error

    ive read about other people having the error message and a lot of people get refferals to use disk warrior, well i have disk warrior 3 and it wil say "directory cannot be rebuilt b/c the disk is unsupported" and theres a line below that that says: "directory cannot be rebuilt b/c this is not a Ma... (it cuts off there).

    i also have taken this HDD twice now and have been able to reformat it with a pc back to ntfs and repartition it. after doing that i would plug it back into my mac and it would mount on the desktop like nothing was wrong.

    the only thing i havnt tried is using disk warrior 3 after it has been refortmated to ntfs to rebuild or reformat it, but i dont even think i can reformat a hdd with DW3 anyway.

    also, ive tried to reformat the hdd with a pc to fat32, but the option isnt available for some reason when i use XP.

    anyway, all i want to do is reformat my HDD to a purely mac compatible format (preferably Mac OS Extended, since it'll only be used as a scrap drive for media). if anyone has any ideas let me know. thanks
  2. Mernak macrumors 6502

    Apr 9, 2006
    Kirkland, WA
    probably not going to be the most helpful of responses but just like to sasy that it seems disk2s10 is given to any disk that the computer cant understand. does the HD show up on the desktop as a readable format (i think it should), and are you erasing the HD factory name(w/brand, size, etc.) or are you trying the sub-drive. I find that the factory name is a more complete erase
  3. bordenkecher thread starter macrumors member

    Mar 24, 2006
    when i plug the hdd (its external and is hooked up by usb2.0) in after its been ntfs formated it will mount to the destop. once i try to reformat to mac OS extended it wont mount, probably b/c it doesnt understand it.

    when ive tried to reformat from the ntfs in disk utility it'll only list the main directory for the drive and ive tried to erase and partition from there.

    *i can reformat it back to ntfs easily, but why cant i reformat it on my mac to Mac OS extended. im positive im doing it in the right order, ive even gone by this guide.
  4. SC68Cal macrumors 68000

    Feb 23, 2006
    Okay, did some homework.

    NTFS file systems are supported under Panther, and can be mounted as Read-Only drives. So that makes sense.

    Try this, open up Disk Utility, go over to the Partition Tab -> Options -> Master Boot Record. That'll create a FAT32 Partition I believe
  5. bordenkecher thread starter macrumors member

    Mar 24, 2006
    yea, it might, but thats not what i want. unless you think i need to format it to fat32 to then format it to Mac OS. but that doesnt make much sense
  6. bordenkecher thread starter macrumors member

    Mar 24, 2006
    so, ive even tried doing different partition settings, in the partition options and none of them have seemed to do the trick. any one else have any idea as to what the problem may be?

    im just trying to reformat an ext HDD (80g seagate) with disk utility and i keep getting the error mentioned above when i verify it. everytime i try to reformate and partition it seems to get hung op in the fist couple of seconds and then later wil come out with an unreadable format essentialy thats not able to mount.
  7. bordenkecher thread starter macrumors member

    Mar 24, 2006
    so the solution to my problem still hasnt been reached. my only other thought would be if anyone knows, can i reformat a HDD to an Mac OS format from win XP since that seems to be the only way ive been able to reformat this HDD successfully.
  8. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    No you cannot. You need to purchase MacDrive6 to format HFS+ in a WindowsXP environment.

    However, I'd be VERY suspect as to why you're getting that error. Disk Utility is not a failure-prone app, IMO. I've formatted hundred (yes hundreds) of disks with DU. I'd be wary that what you actually have is a hardware problem with the disk, or with whatever enclosure you're using.

Share This Page