One of USB ports stops working, until restart!

Discussion in 'MacBook Pro' started by mohalfares, Jan 24, 2014.

  1. mohalfares macrumors newbie

    Joined:
    Sep 17, 2009
    #1
    Hello,

    I've 13 inch early 2011 Macbook pro, 2.3 i5, 16 GB 1333 DDR3, OSX 10.9.1

    And there is something strange just started few weeks ago. One of the USB ports stops working until I restart. Once I restart, it works fine for a day or two, then stops again until I restart!

    It's kind of annoying to do a restart every 2 days :confused:

    Help is appreciated.

    Thanks
     
  2. JamesBrett, Jan 25, 2014
    Last edited: Jan 25, 2014

    JamesBrett macrumors newbie

    Joined:
    Nov 27, 2013
    #2
    same with my macbook air

    my mid-2013 11" macbook air has the same problem, except it's both usb drives which stop working. a restart gets them working again for a few days.

    also, if i have bluetooth turned on, the computer won't find my wireless internet signal.

    i live in tanzania, east africa, and taking the laptop to a shop isn't an option i've got. i'd love if an update somehow fixes these problems....
     
  3. Gman021 macrumors regular

    Joined:
    Aug 21, 2012
    #3
    Had the same issue on my MBA. Had applecare and they replaced that part.
     
  4. mohalfares thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #4
    For some reason, it's been 5 days so far and everyhing is good.

    I'm not sure what did I do. But from my observation, I think the problem was Parallel 8. I think when I launch it, it takes the usb to windows and let it there even after I close Parallels.

    Next time when the USB port stops working, I'll launch Parallels and try to use it there to check.
     

Share This Page