One USB port does not work!

Discussion in 'MacBook Pro' started by DudeMartin, Jun 16, 2011.

  1. DudeMartin macrumors regular

    Joined:
    Dec 2, 2010
    Location:
    Chicago, Illinois
    #1
    Hello everybody.

    I have a quick question. Why does one of my USB ports not work? I have 2011 13" MacBook Pro, i5 version - not upgraded at all.

    If I plug anything into the 'broken' USB port, it simply doesn't respond, well sort of. If I plug a laser USB mouse into the USB, the laser on the mouse lights up (so it is drawing power from the USB) but if I move the mouse around, the actual cursor does not move. Also, if I plug in an iPod to sync it, what happens is the iPod attempts to sync, then all of the sudden acts like it disconnected from my computer, the one second later it attempts to sync again, then it acts like it disconnected again, etc.

    When I was reinstalling the OS, I also ran the Hardware Test and no problems came up. I didn't reinstall because of the USB port, if you were wondering.

    Has anyone else experienced this before? If so, and if you did, how did you solve it?

    I greatly appreciate any input upon this issue! Thanks a lot in advance!
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    Take it back to apple, they may have to replace it for you, as generally issues like that require a new logic board.
     
  3. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #3
    Definitely take it back and get a new one or have them fix it. I would get a new one if its within 14 days.
     

Share This Page