Ongoing Menu Bar Problem

Discussion in 'macOS' started by jlmillstein, Aug 26, 2008.

  1. jlmillstein macrumors member

    Joined:
    Apr 18, 2007
    #1
    The icons on the right side of my menu bar are acting weirdly. They are either invisible, or when clicked, turn blue. The drop down menus rarely work when clicked. I'll attach some photos. On an unrelated note, my computer is requiring my password when i turn it on, even though I don't have that option checked in prefs. This is all on the eve of some weird error where I lost 30 gigs of stuff (I don't really know what I've lost yet) and doing an archive and install. I'm running tiger.
     

    Attached Files:

  2. jlmillstein thread starter macrumors member

    Joined:
    Apr 18, 2007
    #2
    I should have mentioned, It now starts up fine, but when I click on one of the icons to drop down the menus, it turns blue as if it has frozen. Relaunching finder doesn't help.
     
  3. jlmillstein thread starter macrumors member

    Joined:
    Apr 18, 2007
    #3
    This is another example of what it looks like.
     

    Attached Files:

  4. jlmillstein thread starter macrumors member

    Joined:
    Apr 18, 2007
    #4
    I seem to have fixed it. I followed some advice found on the Apple discussions page. If anyone else is having this problem, this is how i fixed it.
    "Apple Menu Bar Icons Gone
    You've probably got a couple of corrupt preference files.

    In "/Users/<yourname>/Library/Preferences", delete com.apple.systemuiserver.plist
    In "/Users/<yourname>/Library/Preferences/ByHost", delete com.apple.systemuiserver.xxx.plist where 'xxx' is a 12 digit (hexadecimal) numeric string.

    This will reset your Menu Bar to the default, you'll need to go through System Preferences to reset the ones you need. (If they are already checked, uncheck them first and then recheck them)."
    good luck
     
  5. cgrendy3 macrumors newbie

    Joined:
    Apr 18, 2011
    #5
    I see that this is an older thread (3 years), and the OS referenced here was Tiger, but I seem to be having the SAME issue with my MacBookPro OS X10.5.8 (Leopard).

    The MENU bar is acting so goofy!! Icons disappear, drop menus won't stay active long enough for me to choose an option, and like the person who started this thread, some icons in the menu bar will stay Blue whether I've used them or not! This has been an intermittent issue for about a month now.

    I can't think of anything lately -- updates, upgrades, downloads, etc. -- that I've done that would cause this issue, and restarting, clearing the cache, repairing permissions, etc. -- the typical 'first fixes' haven't made any difference.

    *** Additionally, (in case it's related) my MBP does not shut down or restart without needing the POWER button to physically shut it off. It seems to boot, or start from a cold start okay, it simply will not shut down from the OS! This problem with shutting down has been going on for about a week. I've listed these issues together because I'm afraid some 'trend' or cascade has started and I don't want more things to go wrong!!! eek. :eek:

    My 10 year old son does use my MPB to surf the net sometimes, but he doesn't download without my approval (I check the history, download file, etc. to make sure he's not bluffing), so aside from his surfing for game cheats or walk-thrus, I cannot find anything unusual.

    As I said before, I've used all the tricks I can think of... so I'm open for any help! I would try the 'fix' that this person has posted, but with the post being so old, I'm hesitant to start messing with files before I know whether those files are still doing the same thing!

    Thanks!
     
  6. jlmillstein thread starter macrumors member

    Joined:
    Apr 18, 2007

Share This Page