Only click (no tap) with 2 fingers for Secondary click

shasoosh

macrumors member
Original poster
Mar 4, 2011
34
1


Just got my new MBP! My problem starts when I want to scroll up or down using the 2 fingers gesture and sometimes the right click menu pops up.

I want to be able to "tap to click" with one finger but "only click with two fingers" for the right click menu aka "Secondary click".

I know I can remove the check mark from "Tap To Click" and by that the secondary click menu will have the option to only click with two fingers BUT I want to keep the "tap to click" and still use the "Only click with two fingers" option.

There is no such option in the trackpad settings. Tried downloading BetterTouchTool but the options there, regarding two finger click, are also limited.

Is there a way to accomplish the above?
 
Last edited:

xnview

macrumors member
Jun 21, 2013
34
1
If your problem is that you accidentally right click when scrolling, you just have to learn not to tap when scrolling?

You shouldn't tap when scrolling, just swipe your fingers
 

shasoosh

macrumors member
Original poster
Mar 4, 2011
34
1
I prefer just to disable the tap with two fingers solution, if something like that is possible.
 

snaky69

macrumors 603
Mar 14, 2008
5,904
481
I prefer just to disable the tap with two fingers solution, if something like that is possible.
It's not possible no. I've never had that problem though, simply learn not to tap when scrolling, it isn't that hard.
 

priitv8

macrumors 68040
Jan 13, 2011
3,544
447
Estonia
I prefer just to disable the tap with two fingers solution, if something like that is possible.
Why don't you just remove the checkmark from the Secondary Click box in Trackpad preferences? Or reassign it to a one-finger click in the corner?
PS Even with Secondary click disabled here, it will always be available via primary click whilst holding down the Ctrl key.
 

shasoosh

macrumors member
Original poster
Mar 4, 2011
34
1
Why don't you just remove the checkmark from the Secondary Click box in Trackpad preferences? Or reassign it to a one-finger click in the corner?
PS Even with Secondary click disabled here, it will always be available via primary click whilst holding down the Ctrl key.
Thanks for your reply. I'm aware of all the other ways to get the right click menu but couldn't adjust to any of them. I hoped for a hack / terminal command to disable the two fingers tap and keep the two fingers click.