Only left side of headphone/speaker is working

Discussion in 'OS X Yosemite (10.10)' started by Psittacus, Jan 13, 2015.

  1. Psittacus macrumors newbie

    Joined:
    Aug 7, 2012
    Location:
    Portugal.
    #1
    Hey,

    So last month I bought a 13" rMBP (now running Yosemite 10.10.1) and yesterday while trying out a subwoofer I got, it started playing out only the left side of headphones or speakers. I know it's not the headphones cause I've tried it on other devices and no matter what is plugged in to it, on only comes out left side.
    From the forums I've read it doesn't seem to be a sound card or the logic board, otherwise it wouldn't be working at all. The most logical explanation is that the connection inside the jack is messed up, but the mac is only 1 month old.
    I've checked the setup on sound preferences and Audio MIDI Setup and both seem fine.

    [​IMG]

    [​IMG]

    Does anyone know how to fix this without taking it to warranty service?
    Thanks.
     
  2. Psittacus thread starter macrumors newbie

    Joined:
    Aug 7, 2012
    Location:
    Portugal.
  3. GP-SE macrumors 6502

    Joined:
    Feb 27, 2013
    #3
    did you plug the subwoofer directly into the Laptop? if so then you may have damaged the logic board. Do the internal speakers work fine?
     
  4. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #4
    You've actually moved the balance control to left and right?
    Sometimes prefs get messed up relative to display, and need rewriting.

    What happens when you rotate the headphone jack while listening to music?
    A bad connection will often be noticeably intermittent.

    What about the Mac's internal speaker(s)? Do you get both left and right from them?
     
  5. Psittacus, Jan 15, 2015
    Last edited: Jan 15, 2015

    Psittacus thread starter macrumors newbie

    Joined:
    Aug 7, 2012
    Location:
    Portugal.
    #5
    No I didn't pluged it directly. :) Yes, internal speakers work just fine and balanced.

    Yes I did, it didn't fixed it.
    Internal speakers work just fine and balanced.
    I've tried with several headphones, also tried to rotate the headphone jack and right side doesn't give a single noise. :(

    Thank you both for your help.
     
  6. Pudlo macrumors member

    Joined:
    Apr 3, 2014
    #6
    Just take it to apple store. It's a new mac so it shouldn't happen but...it can ;)
     

Share This Page