Only one channel on headphones when connected

Discussion in 'MacBook Pro' started by jokkesvin, Sep 15, 2008.

  1. jokkesvin macrumors newbie

    Joined:
    Nov 17, 2007
    #1
    Right out of the blue, my Macbook Pro decided to only let one channel play on my headphones. They work perfect on my iPod. I've tested them with iTunes and other programs to exclude a software error and yes, I made sure that the audio balance is even.

    What might be the problem here??

    I remember bumping the Macbook Pro on the table by accident (it was inside my neoprane casing). But it must take more to break something inside it, right?
     
  2. jokkesvin thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #2
    An update

    Ok, now suddenly the right speaker went out too :( What is going on here??? They both worked a minute ago...
     
  3. jokkesvin thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #3
    Solution

    Ok after having talked to my friend Anders Baden Nielsen about it (who is a Mac wizard!) he told me to try restarting while holding down apple+alt+p+r to clear the PRAM. I did that about 4 times and when I came back to OS, everything worked :)
     
  4. jokkesvin thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #4
    Yet another update

    ...ok, now the problem is back again.

    Is anybody experiencing the same?
     
  5. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  6. jokkesvin thread starter macrumors newbie

    Joined:
    Nov 17, 2007
    #6
    But...

    But both speakers work perfectly, but when I plug in headphones, there's only sound on the left channel.
     

Share This Page