Only one key is not functioning in keyboard of my MacBook Pro

Discussion in 'MacBook Pro' started by cooldesignz, Jan 9, 2009.

  1. cooldesignz macrumors newbie

    Joined:
    Jan 9, 2009
    #1
    "P" key is not working properly, when it is pressed it comes along with Keyboard light icon and start the light in keyboard. But when "Caps lock" is on it works perfectly fine. It just doesn't work when I press in normal mode. Is this any sort of software problem or hardware???

    Is some one is also having same kind of problem? I got this problem just doing nothing. I left my MBP turn on and didn't kept in sleep mode. Please let me know some suggestions if you have any... any suggestions are highly appreciated. Thanks...
     
  2. xpovos macrumors 6502a

    xpovos

    Joined:
    Jun 7, 2007
    Location:
    Tennessee
    #2
    I had this problem---oddly enough, with exactly the same key!

    Since the issue presented itself literally just hours after I had picked up the machine after a logic board replacement (to address screen flicker that, it turned out, the new board did not fix), I called AppleCare then and there, from the store, to firmly request a replacement unit. (I had owned the unit for 32 days, 20 of which it had been in shop for repairs. The "P" key would have been the fifth repair.)

    It's probably a software issue. When I had gotten mine back to the store, of course the problem had vanished and all keys were working properly. But by that time I had had enough. I told the AppleCare product specialist that I had, as a result of all these needed repairs, lost all faith in the future reliability of that particular unit, and that I thought Apple should provide a replacement. They gladly did so.

    The new unit, which I'm using now, is the fourth one in a row I've had with the issue of screen flicker at low brightness when on battery power. I've abandoned all hope of finding one without the issue, opting instead to hope that a driver or firmware update can fix it.

    Kinda hard to wait on an update that allows you to use words containing the letter "p", though, isn't it?
     
  3. cooldesignz thread starter macrumors newbie

    Joined:
    Jan 9, 2009
    #3
    Hi - Thank you for the response. I've discovered the solution for this weird problem. I was just trying out every chances...and it is working perfectly fine... NO NEEDED TO CHANGE THE KEYBOARD OR ANY OF THE HARDWARE... let me know if some one has same problem...
     
  4. celltower macrumors newbie

    Joined:
    Feb 14, 2009
    #4
     
  5. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #5
    +1 ^^^ Too funny; I would be issed off as well...:D
     
  6. earthandtone macrumors newbie

    earthandtone

    Joined:
    Jan 28, 2009
    #6
    How do you fix it. mine does that on the mac book pro? it is pissing me off so bad...
     
  7. himkawong macrumors newbie

    Joined:
    Apr 14, 2010
    #7
    I've very similar 'p key Problem (lower case p and shift-p doesn't work, but CAPLOCK p works). Do anyone have any solution ? Thanks.
     
  8. Hellishness macrumors 65816

    Hellishness

    Joined:
    Jan 27, 2010
    Location:
    Bay Area, CA
    #8
    do you guys (anyone with this problem) have the latest (arrandale/new 13") macbook pros or older ones?
     
  9. himkawong macrumors newbie

    Joined:
    Apr 14, 2010
  10. MacBob1240, May 11, 2011
    Last edited: May 11, 2011

    MacBob1240 macrumors newbie

    Joined:
    Dec 23, 2009
    #10
    I am experiencing his same problem wih he T key.

    Sorry about the missing T's in the title. I am using Keyboard Maestro to supstitute a copy and pasted t with keystroke of control T keystroke. Very un-handy.

    I had my screen replaced. I experienced a repeat of the screen problem for a short period, but then it cleared up. To be sure it was going to work ok, I left the MBP on overnight streaming video from my Slingbox. The screen is still working fine, but the missing T problem appeared.

    In reading this string, I did not see a solution. My MacBook is an early 2008 (the last pre-uni-body MBP), so I am not under Apple Care and cannot carry it back to the Apple Sore and demand a replacement.

    If I use Parallels and Windows XP Pro, which I have installed, the T key works normally??? Must be in the Mac's Keyboard driver software.

    If you have a fix, please let me know.
    Thanks,
    Bob White
     
  11. elley macrumors newbie

    Joined:
    Jul 9, 2011
    #11
    help!

    Hello, to the thread starter, could you please tell us what worked for you? i have the EXACT same problem... and its driving me crazy!!!!!!!!!:confused:

    thankyou very much! :D
     
  12. Kush OG macrumors newbie

    Joined:
    Nov 7, 2011
    #12
    The original poster has not returned since they told us: "I've discovered the solution for this weird problem. I was just trying out every chances...and it is working perfectly fine."

    What does that even mean? Trying out every chances? Because that is this person's suggestion for solving the problem.

    Anybody else figure out the solution to this problem other than the selfish person who didn't want the rest of us to benefit from this thread?
     
  13. duckhead macrumors newbie

    Joined:
    Dec 29, 2011
    #13
    Sticky 'P' key fix

    Although this thread is a bit aged, I thought I'd post what I found about this issue for those who stumble upon this in the future.

    A friend's daughter had the same issue on her 2010 15" MBP. She typically got it into the inoperable 'P' key mode soon after bringing it out of sleep. So with it in that mode here's what I found:

    • The Caps Lock is also inoperable (that and the 'p' key are the only non-functioning keys).
    • Logged out of the account and into another Admin account - no effect: the 'p' and Caps Lock were non-functional
    • Brought up the virtual Keyboard Viewer: that verified that the Caps Lock and 'p' were not receiving input from the top case keyboard.
    • Using the mouse on the Keyboard Viewer for the Caps Lock and 'p' key worked normally - the key input was received.
    • I didn't have an external keyboard available at the time, but I suspect it would work.
    • I was able to get it into and out of the mode repeatedly by putting to sleep and waking up - it seems highly correlated to waking up from sleep.
    • When in the non-functional mode, I was generally able to get it back to normal by holding down the <Option><Command> keys while hitting the Caps Lock repeatedly (although one time this made the Caps Lock stick 'on').

    I took it to an Apple authorized service center and luckily the 'p' key was inoperable for them and they were able to diagnose it as a faulty logic board. They replaced the board, and it's been fine ever since (about 7 months now).

    Sorry there's not an easy fix that I know of.

    D
     
  14. BradMacRumors macrumors newbie

    Joined:
    Apr 15, 2014
    #14
    I had a very similar problem for two days. Either "p" wasn't recognized or it typed "-" or "p0" plus "enter" or changed the volume. No keys around it were affected. I saw that it worked in CAPS for the poster and tried it and it worked and then for whatever random reason, it started working normally as soon as I turned CAPS off. No idea why, but worth a try for anyone else with the problem.
     
  15. whittaker007 macrumors newbie

    Joined:
    Sep 22, 2008
    #15
    I have exactly the same problem as the last two posts - 'p' key stopped working, when pressed will instead output any combination of p 0 - \ ? / volume down, enter, or power off.

    Like the above post, the caps lock key is also affected, but unfortunately pressing it repeatedly (in combination with other keys or not) does nothing to improve the situation. Nor does sleeping and waking the machine.

    Extremely frustrating since my login password contains the letter 'p' which prevents me from even logging in. And the Applecare warranty expired about 5 months ago.

    I'm taking it in to be examined - I'll update the thread if it turns out to be anything other than a failed logic board which seems the most likely scenario. If that's the case it's probably not worth fixing.
     
  16. BradMacRumors macrumors newbie

    Joined:
    Apr 15, 2014
    #16
    Mine has gone south from when it worked before, unfortunately. I can copy a p and then paste it with Command+V, or type it with the Keyboard character viewer, which you can bring up in the toolbar in Settings under Keyboard. For your password, boot into safe mode (power down, wait ten seconds, then hit power and immediately hold down SHIFT) and then you should be able to change the password from there I think.
     
  17. Felasco Guest

    Joined:
    Oct 19, 2012
    #17
  18. BradMacRumors macrumors newbie

    Joined:
    Apr 15, 2014
    #18
    I saw some stuff about remapping, but couldn't find the right resources. This could be MASSIVELY helpful if it works. Thanks.
     
  19. whittaker007 macrumors newbie

    Joined:
    Sep 22, 2008
    #19
    In my case the issue was caused by a damaged daughter board or connecting ribbon cable:

    Our diagnosis results shows that your Macbooks Daughter Communication board is faulty and need replacement. No visible signs of liquid and power surge, the only possible way this could happen is due to extra pressure applied on trackpad. This is a common issue with this specific model.

    I have a late 2010 11" MacBook Air.
     
  20. jeet87 macrumors newbie

    Joined:
    Aug 11, 2014
    #20
    Hey, i have the same PROBLEM, MY MAC IS OUT OF WARRANTY, CAN ANYONE GIVE ANY SUGGESTIONS?
     
  21. LooNeyCinTa macrumors newbie

    LooNeyCinTa

    Joined:
    Oct 1, 2015
    #21
    I still got this ‘PROBLEM That still can't solve ...
    Could you
     
  22. LooNeyCinTa macrumors newbie

    LooNeyCinTa

    Joined:
    Oct 1, 2015
    #22
    I still got this ‘PROBLEM That still can't solve ...
    Could you Please help me with this...?
     
  23. amandajs macrumors newbie

    Joined:
    Nov 28, 2015
    #23
    Just discovered a work around on my Macbook 2008 while looking on this forum for a solution. The zero on my keyboard stopped working about 4 days ago. I have checked to see if my speech recognition thingy and mouse thingy are off. They are. If I go into Language preference and click on "show keyboard viewer" I can click on the zero key on the keyboard viewer with the mouse pad and get either a zero or one of these )
    It isn't a fix, but it will do until I can clean under the key or buy a new computer. Hope the work around will help others (although a letter key would be more of a hassle I suppose}
     

Share This Page