only windows works!

Discussion in 'MacBook Pro' started by ibd, Jul 10, 2012.

  1. ibd macrumors member

    Joined:
    Apr 12, 2008
    #1
    Hi!

    My early 2008 machine will only boot into Windows 7!

    When trying to boot into SL, which is also installed, I get a blue screen of death before the log in screen appears.
    When trying to boot from an external HD/Recovery HD, the same thing happens..

    I tried to zap the pram, but NOTHING HAPPENS, the key strokes are just ignored. The only thing that works is holding alt to select windows from the bootable devices.

    Some times I get to the log in screen, but all keystrokes and trackpad input is ignored! Which is weird because they work fine under windows AND in the boot drive menu.

    Please help!

    Cheers, ibd
     
  2. Cisco_Kid macrumors 6502

    Cisco_Kid

    Joined:
    Apr 24, 2005
    Location:
    British Columbia
    #2
    Try booting from the recovery CD, then use the Disk Utility to check the drive, it might make a repair to the EFI Boot Partition for you.
     
  3. ibd thread starter macrumors member

    Joined:
    Apr 12, 2008
    #3
    Solution

    Cisco_Kid, appreciated. But your hint did not help me, because I was unable to boot any OS X (see below).

    For future googlers, I post the solution:

    1. I had open firmware password enabled. I later found out that this DISABLES most keystroke combinations such as: PRAM reset, start apple hardware test, single user mode... but most importantly safe boot, which was the key to fixing my problem!
    So, I had to boot with the alt key first. Then, enter the firmware password. This makes the mac unlock all the keystroke combinations! So I was able to boot up in safe mode (hold shift).
    Then, I put in an old OS X install DVD, from which I ran the "open firmware password utility", then disabled it.

    2. I checked single user mode (cmd-s) and the console.app, both showed recurring lines of "firewire error", about 50 messages per minute!!
    This means that OS X will not boot when the firewire hardware has failed! In contrary, this was ignored by windows which was the original reason the thread is called like this. ;)
    To remedy this, I deleted /System/Library/Extensions/IOFireWireFamily.kext! This "fixed" my macbook pro to the point that I'm able to use it normally again, except for the firewire port which is now missing instead of being reported with an error by system profiler.

    Thanks for looking, see ya
    -ibd
     

Share This Page