"Open in Background" on iPhone 8

Discussion in 'iPhone' started by Nermal, Sep 21, 2017.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    Hi all,

    I'm having an issue with my iPhone 8. Previously in Safari I could tap and hold on a link. After a second or so it popped up with a menu where I could choose "Open in Background" to open the page without losing the page that I was currently on.

    On my new phone, I tap and hold, but the menu doesn't appear after a second. I've held for a few seconds and nothing appears, but when I let go the menu pops up... and the page loads in the foreground. If I then tap on Open in Background then I end up with two copies of the page.

    This doesn't seem to be an issue with iOS 11 itself, as it still worked correctly on my iPhone 6 after upgrading. Has anyone else run into this on an 8?
     
  2. soloer macrumors 6502a

    soloer

    Joined:
    Sep 27, 2004
    Location:
    Omaha
    #2
    I don’t have my 8 yet, but I experienced sporadic behavior with tap and hold while using the ios11 beta.
     
  3. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #3
    I think the delay is due to iOS 11's drag and drop feature. As long as you're holding the item it can be dragged (on iPads). Only when you release the button without dragging might the OS know that you want to see the contextual menu. This is just speculation.
     
  4. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Before posting it seemed to be consistently failing the same way, but now I'm sometimes having it work and sometimes not. When it fails, the screen goes blurry for a fraction of a second. It's really weird!
     
  5. pat500000 Suspended

    pat500000

    Joined:
    Jun 3, 2015
    #5
    I don't have 8, but did you try to do reboot? or back up and restore?
     
  6. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    I'm working on backup/restore now. I'd transferred my settings from my previous phone with the new "line up the circles" process, but it didn't work correctly. Now that I'm home from work I'm doing a proper backup and restore via iTunes.

    It refuses to talk to iTunes 12.6 so I'm having to make a final backup of all my .ipa files before begrudgingly installing 12.7...
     
  7. flashflooder macrumors 6502

    Joined:
    Oct 14, 2011
    #7
    If the screen is going blurry it means you’re inadvertently activating 3D Touch. You can adjust the activation pressure in settings.
     
  8. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    Thanks, but apparently not. I've disabled 3D Touch and I'm still having the same issue.

    For the benefit of anyone else in this thread, you can disable 3D Touch in Settings/General/Accessibility/3D Touch. Inexplicably, searching for "3D" doesn't find it, so it was a bit of a hunt!

    Edit: Hmm! One of the pages I'm testing with is my personal site, which is plain HTML with no JavaScript (and very little CSS for that matter). At the default zoom level I have the issue, but when I zoom in then the issue goes away. Bizarre...
     
  9. bmac89 macrumors 65816

    bmac89

    Joined:
    Aug 3, 2014
    #9
    I don’t have an iPhone 8 but I do notice a huge delay with the menu popping up when Safari is in multitasking mobile view on my iPad. The reason for this is for drag and drop on the iPad.

    However I did notice if you press and hold until the link expands for drag and drop and then immediately release the menu pops up without further delay. Now I’m in the habit of press & hold and release. Not sure if any of this is help for iPhone though.
     
  10. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #10
    Perhaps try toggling on/off Safari’s content and privacy settings?
     

Share This Page

9 September 21, 2017