"Open In..." not working for large files in iOS 5

Discussion in 'iOS 5 and earlier' started by JTravers, Oct 23, 2011.

  1. JTravers, Oct 23, 2011
    Last edited: Oct 24, 2011

    JTravers macrumors 6502a

    Joined:
    Jun 28, 2010
    #1
    I couldn't find this being discussed anywhere else (if it has been discussed, please point me to the thread).

    When I try sending a large file (for example, a 500MB video I edited and uploaded to Dropbox) from one app to another using iOS's "Open In..." functionality, the file transfer starts and then aborts soon thereafter. When I 1st execute the "Open In...", I notice that space for the file is reserved (the free space on my iPad drops by 500MB), but after a minutes or so the space magically comes back and the file is never sent to the app I selected from the "Open In..." menu. I know this used to work with large files because in the past (as recently as 2 weeks ago) I've sent video files as large as 1.5GB from the Dropbox app to Goodreader and Goodplayer.

    I found this same problem addressed in the 3rd question of the iCab FAQ.
    http://www.icab-mobile.de/faq.html

    This new "feature" of iOS 5 makes the iPad much less useful for seamlessly moving my video files around.
     
  2. Rubo Draco macrumors regular

    Joined:
    Sep 21, 2011
    #2
    I've used that feature to open 700MB files... I just have to be patient (takes like 3 to 5 min)
     
  3. JTravers thread starter macrumors 6502a

    Joined:
    Jun 28, 2010
    #3
    Have you used it since upgrading to iOS 5?
    I've tried opening multiple files from 500MB to 1.5GB in size, and none opened (I waited 10-15 mins for each).

    Would you mind trying again (assuming you've upgraded to iOS 5)?

    Thanks!
     
  4. Rubo Draco macrumors regular

    Joined:
    Sep 21, 2011
    #4
    I just did it last night to watch Edward Scissorhands movie... Which was a 475MB file, but I've done it with other bigger movies.
    and yes, I am on iOS 5
     
  5. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #5
    Just tried it with a 2.5GB zip file. Worked in about 1 minute.
     
  6. JTravers thread starter macrumors 6502a

    Joined:
    Jun 28, 2010
    #6
    Interesting. What apps were you sending the file to and from?

    Maybe it's because I'm down to only 2.5GB of free space? I'll clear some room and try again.

    Thanks for the feedback!

    ----------

    Thanks for verifying. What apps were you sending the file to and from?

    It looks like I need to experiment a little more to see why it's not working for me.
     
  7. JTravers thread starter macrumors 6502a

    Joined:
    Jun 28, 2010
    #7
    Okay, looks like I solved the problem. With only 2.5GB free, I couldn't "Open In..." any large files (I tried 500MB and 1.4GB files). After clearing some space and ending up with 7GB free, I could successfully "Open In..." the 500MB file. The 1.4GB file still won't work, though. Looks like I'll have to clear a little more space and try that file again.

    Thanks to everyone for your input. :)
     
  8. Rubo Draco macrumors regular

    Joined:
    Sep 21, 2011
    #8
    From iDownloads to Flex:player
    good to know that you solved it!
     
  9. JTravers thread starter macrumors 6502a

    Joined:
    Jun 28, 2010
    #9
    Actually, it's acting pretty flaky. One time it will work and another time it won't. Not exactly sure why. Maybe it isn't linked to free space after all (beyond the fact that you need enough space to make a copy of the file).
     
  10. Havner macrumors newbie

    Joined:
    Nov 10, 2010
    #10
    Finally, someone noticed this as well. I can confirm this 100%.

    Happened since ios 5 and is not related to any specific app. I have this problem while transferring files ~1GB between two different sets of completely independent apps.

    What struck me though is that it doesn't look like a deliberate action from apple because it does work sometimes. Once per ~30 tries.

    I usually check how much space is left, open an app, choose a file, hit open in as many times as I have space left (~10). Then I get a msg that my free space is running out. I open usage in settings and observe how my free space is being restored when one after another operation fails. Sometimes one will succeed.

    I really hope this is a simple bug and will be fixed at some point cause it made my pleasure from using iPad go away completely recently.
     
  11. RoboCop001 macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #11
    It seems that every time you do an "Open In..." it copies the file.

    I don't like that it works that way. Can't it just place the file in a "public" folder that all apps can access? And if you make edits to it, then it will save the new version.
     
  12. Rubo Draco macrumors regular

    Joined:
    Sep 21, 2011
    #12
    the bigger the folder, the slower the access (and that would be for all the apps)... altough, it would be nice if we could decide which apps can share their content
     
  13. Rubo Draco macrumors regular

    Joined:
    Sep 21, 2011
    #13
    The only thing I can think of is that iOS 5 is aborting your request cause of the "long time task"... Try clearing your taskbar and just keep the two apps you need (the "From" and the "To")
     
  14. Havner macrumors newbie

    Joined:
    Nov 10, 2010
    #14
    Tried it all. Rebooting, clearing all apps in the background.

    The fact is nothing helps and none of this was required in iOS4.

    ----------

    It's not. I made above 15GB of free space. Didn't help either.
     
  15. Donfisa macrumors newbie

    Joined:
    Nov 9, 2011
    #15
    Finally

    Man , this has been driving me crazy for a couple of weeks. I have been trying to transfer vids over 500 from DownloadsHD to AVPlayerHD...tried everything. Have had to resort to wifi transfers. Has completely ruined my use of the iPad. What can we do? Is someone from Apple listening?
     
  16. Havner macrumors newbie

    Joined:
    Nov 10, 2010
    #16
    What can I say?

    Ditto...
     
  17. dan44 macrumors newbie

    Joined:
    Mar 22, 2010
    Location:
    Switzerland
    #17
    workaround

    Ok, i had the same problem as written in many posts above (larger files won't open in other apps). In my case i want to open a movie (.avi) which is in "Downloads HD" in "Goodplayer" on my iPad. Here is how it worked for me on iOS 5.0.1:

    1. I renamed the file "xy.avi" to "xy.zip" in Downloads HD.
    2. Transfered the renamed file with the "open in" option to Goodplayer
    3. In Goodplayer I renamed it back to "xy.avi" (to do that the file has to be in the main folder not in the inbox...)

    IMPORTANT: in Goodplayer the file was not visible when i opened the inbox. But it was there when i navigated to the inbox via "folder options" (bottom left corner of the app).


    This worked for me with a 1GB file so far.
     
  18. Havner macrumors newbie

    Joined:
    Nov 10, 2010
  19. Google12345789 macrumors newbie

    Joined:
    Nov 13, 2011
    #19
    Solution



    This is my solution. iPad 2 ios 5.0
    when I'm in Downloads I push the button "open in" AvPlayer or OPlayer or GoodPlayer (it works with all of them) over and over again until the system tell me that there in no more space (2 buttons in the message box, 'end' and 'settings', I choose 'settings'). Then in settings I see "free space" that push up. After 1-2 minutes in the folder Inbox of Avplayer/oplayer/goodplayer I find the file .Avi
     
  20. flapee macrumors newbie

    Joined:
    Nov 13, 2011
    #20
    More or less the same problem as the poster,

    except trying with 350MB files ( in application Filer ) (free space at ~5 GB )

    with the iOS 5 i've noticed another issue ...
    I used to be able to play more or less any AVI file in the FILER app ( or any other supporting the embed player for that matter), but does not work any more ... the player loads, shows the length of the file. but wont play the content

    anyone some thoughts?

    P.
     
  21. romaha macrumors newbie

    Joined:
    Nov 17, 2011
    #21
    post a remark @Apple !

    Same problem here.

    I suggest everybody to add a remark on the apple support page to get some attention and get this problem high on their bug-fixing list.

    there is already a topic created here
     

Share This Page