Open With setting not nbeing remembered afetr restart

Discussion in 'Mac OS X Lion (10.7)' started by EquatorDesign, Oct 12, 2012.

  1. EquatorDesign, Oct 12, 2012
    Last edited: Oct 12, 2012

    EquatorDesign macrumors newbie

    Oct 12, 2012

    Apologies if this has been asked before, but a search of this forum has not brought up an answer.

    My problem is this. I have set up three users in our studio running Lion. On each Mac there are two accounts - an admin account with full privileges (install software, change settings etc) and a user account with limited preferences. On the user account I want to set it so that PDFs automatically open up with Acrobat, not Preview. I select a PDF, do File/ Get Info, and change it to Open With Acrobat and select Change All... This works fine until the Mac is restarted and then Lion forgets this setting and reverts back to Open With Preview.

    The same happens with .doc and .docx files which I set to open in NeoOffice instead of TextEdit, but which revert back to TextEdit once restarted.

    Anybody else get this? It happens on all three of the Macs I've set up. Might it be because the user accounts do not have administrator privileges?

    Thanks in advance for any replies,


    PS Sorry for typos in subject title!!
  2. justperry, Oct 12, 2012
    Last edited: Oct 12, 2012

    justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Try repair permissions first.

    The file(s) which are responsible for which Application is launched are in the main Caches folder.
    I have two here, one for the root user (o), which is enabled on My system and one for the User(Me-501).

    You should have at least two, maybe three if root is enabled.

    Mine are named: which is the root user 0.
    Permissions are System-R/W, Admin-R, Everyone-R chmod 0644 which is Me 501.
    Permissions are Me-R/W, Everyone-R chmod 0600

    First look if you have such a file for each user, and if that is the case set it so that you have permissions to R/W.

    Edit: You should also check the permissions for the cache folder, might be set wrong, also weird that it's the same on all the computers.

Share This Page