"Open with" shows dual entries of apps

Discussion in 'Mac Basics and Help' started by hafr, Jul 25, 2012.

  1. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #1
    I use the option "open with" quite often since it's easier for me than first opening the app I want to use. Yesterday I updated an app and now there are dual entries of that app.

    How do one go about to edit the list of apps for a specific file format? I only know how to add apps, not remove them...
     
  2. hafr thread starter macrumors 68030

    Joined:
    Sep 21, 2011
    #3
    Yeah, I tried those before creating the thread, without success. Although I just got the brilliant idea to restart Finder via the killall command, which seems to have made it work.

    I'm guessing the trick did work, but in ML you have to kill Finder in order for it to show...

    Thanks.
     
  3. DoctorDiseno macrumors newbie

    Joined:
    Sep 20, 2012
    #4
    I had same problem in ML and previous solutions didnt work. Did some experiments and got this:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister \ -kill -r -domain local -domain system -domain user

    Try it, worked for me! Hope it helps someone :)
     

Share This Page