OpenAL Xcode Issue?!

Discussion in 'Mac Programming' started by Blakeasd, Jun 29, 2011.

  1. Blakeasd macrumors 6502a

    Dec 29, 2009
    I have been having numerous issues with the Cocos2dBox2d mac template and now I am getting yet another strange error:
    "ld: warning: ignoring file /Developer/SDKs/MacOSX10.6.sdk/Library/Frameworks//OpenAL.framework/OpenAL, file was built for unsupported file format which is not the architecture being linked (i386)"
    I changed the architecture to x86_64 and I get the same error, why is this happening and how can I fix it :confused:
  2. jiminaus macrumors 65816


    Dec 16, 2010
    Where did this OpenAL.framework come from?
  3. XcodeCrazy macrumors newbie


    Jun 30, 2011
    The OpenAL.framework is located in: /System/Library/Frameworks/. The Active Configuration in your Xcode Project is the only thing that should be modified after the project has started. Changing the project's architecture can affect the whole project (in this case, x86_64 & i386). Have you tried modifying the project's Active Configuration? If so, you may have to revert back to the default Debug | x86_64 and modify certain lines of code. You may also want to try reverting back to your projects original Active Target, entitled with the original name of your project (instead of the reverted cocos2d libraries file you've likely created). Tweaking with these little things can prove to be helpful in the long run. Hope you found this helpful! Please write back if you have further questions! :)

    Matt Thompson
    June 30, 2011
  4. Blakeasd thread starter macrumors 6502a

    Dec 29, 2009

Share This Page