OpenBackup won't restore

Discussion in 'Jailbreaks and iOS Hacks' started by petrucci666, May 26, 2012.

  1. petrucci666 macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #1
    Wirelessly posted

    Like everyone else, I jailbroke with Absinthe.

    Before that I was on a tethered jailbreak with 5.1.1 on an iPhone 4 GSM.

    The trouble I'm having is with restoring tweaks via OpenBackup.

    I know it can use iCloud for backups and restoring but I'm a bit skeptical about that so before upgrading the OS or anything, I extract the OpenBackup files to my hard drive. After the upgrade, I download OpenBackup from Cydia, go to the OpenBackup folder on the iPhone root (using iExplorer) and paste the files I had on my hard drive. After that I click restore in the OpenBackup app. It worked when I was loading the tethered jailbreak, but now it won't restore.

    I've been trying all day and can't get it to work.

    I had a ton of tweaks that I simply can't remember to go download again one by one.

    Help please!
     
  2. iRooney macrumors 6502

    iRooney

    Joined:
    Jul 14, 2011
    Location:
    Charleston, SC
    #2
    You should've just stuck with iCloud. Worked flawlessly for me.
     
  3. petrucci666 thread starter macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #3
    Wirelessly posted (iPhone)

    I tried restoring from iCloud in the past but it never worked. So now I only do manual copies.

    The problem isn't my method, it's that OpenBackup isn't doing what it says it does.
     
  4. chicoquente macrumors newbie

    Joined:
    Jun 6, 2011
    #4
    Where does OpenBackup store its files? I updated and the restore is not working for me (I do not use iCloud as of yet, still MM as I am on Snow Leopard) on 5.1.1 on my iPhone 4. I used iPhone Backup Extractor and get the files from my old backup but don't know where they belong on my phone. I want to double check they did in fact make it back after the restore.
     
  5. petrucci666 thread starter macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #5
    I use iExplorer to see root files of the iPhone.

    You go: root-private-var-mobile-library-preferences-openbackup files


    There you just copy and paste those files from that location to your hard drive.
    Then you upgrade, rejailbreak, download openbackup from Cydia, go to the same location in iExplorer and paste the files from your hard drive to the openbackup folder on your iPhone.

    After that you go to the openbackup app on your phone, click restore, reboot and everything should be there. I've done this more than once in the past and it always worked. Now, after jailbreaking with Absinthe it doesn't work for some reason and I have yet to figure out why.
     
  6. bubba*nix macrumors member

    Joined:
    Aug 9, 2004
    Location:
    Raleigh, NC
    #6
    The problem is when you install OpenBackup I believe it creates a backup. The files are in ~mobile/Library/Preferences/OpenBackupFiles. I backed up my files w/ OpenBackup then backed up my device via iTunes (I also backed up my Cydia data via another method I use that's always worked, but I cannot automate/schedule like OpenBackup). I then upgraded, jailbroke, restored data from iTunes, installed OpenBackup. I then tried to do an OpenBackup restore for Cydia and it looked like it was doing something, but didn't work (it never has). I logged in and looked at the backup file and it was created the time OpenBackup was installed, thus it didn't install anything new AND overwrote my old backup. Luckily I had my other method and was able to restore.

    My OpenBackup options are set to be every 24 hours and NOT on reboot. I once thought that the device rebooted after OpenBackup restore, and when that failed I couldn't try again because I thought it had created a new backup on restore. Instead, I think OpenBackup is just broken. The author needs to not overwrite old backup files and give you the option to restore to the info in an older backup file. That should resolve most of the issues.
     
  7. petrucci666 thread starter macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #7

    I finally resolved the problem, but not with the openbackup files I had saved before the jailbreak. I resolved it by using older openbackup files from a week or two earlier when I was doing a tethered jailbreak on 5.1.1. with redsn0w.

    It took me almost 40 hours to figure everything out and it was driving me insane, but thankfully it worked out.
     
  8. ColinV macrumors newbie

    Joined:
    May 28, 2012
    #8
    I have the same problem. I've found a previous version of the bckup files using backup extractor and loaded them into the preferences/OpenBackupFiles directory. The bckup.txt file appears to have all of the packages. But when I restore with OpenBackup, I don't get them. It's restoring something as my icons get moved around, but not the right files. Any suggestions?
     
  9. nheinrichs macrumors newbie

    Joined:
    May 29, 2012
    #9
    This worked for me, 4.3.3 -> 5.1.1 + OpenBackup

    In my case, I had a repo/package in my backup files that was no longer available (mobilenotifier.)

    I noticed the problem by looking at OpenBackup's "Error Log". Cydia didnt care about the broken repo, but it was causing OpenBackup to abort my restore.

    1) Find your backed-up bckup.txt and .zip on your laptop.
    1.1) Edit bckup.txt and remove any line with "mobilenotifier"
    1.2) Unzip bckup.zip, remove the line containing "http://phajas.xen.prgmr.com/repo/" from etc/apt/sources.list.d/cydia.list, and recompress everything back into bckup.zip
    2) Open OpenBackup on your phone
    3) Copy your doctored bckup.* files to the phone: scp bckup* root@<phones ip address>:/var/mobile/Library/Preferences/OpenBackupFiles
    4) Click 'Restore' in OpenBackup
    5) Reboot your phone (I actually had to reboot twice before everything was in order.)

    Hope this helps someone.
     

Share This Page