OpenCV and WxWindows Xcode4

Discussion in 'Mac Programming' started by kristianmoss, Apr 20, 2011.

  1. kristianmoss macrumors newbie

    Mar 17, 2011
    So my problem is that I have found this code (C++) that uses both OpenCV and WxWindows. It's not my program but an OpenSource program that i'm trying to write a small plugin for.

    But I have no idea how to get Xcode to recognise the headers for these two programs.
    I'm pretty sure that I have installed them both correctly, but I still get these issues:

    'wx/wx.h' file not found

    'cv.h' file not found

    'wx/wxprec.h' file not found.

    I have not been able to find any help on that is related to Xcode 4, so I'm hoping you can help me.
  2. jiminaus macrumors 65816


    Dec 16, 2010
    Where have you installed OpenCV and wxWidgets? Are they frameworks or dylib libraries? Have you added the framework or dylib to the Link Binary with Libraries build phase of your target? If they're dylibs, have you additionally added the path(s) to the header files to the Header Search Paths build setting of your target?
  3. kristianmoss, Apr 20, 2011
    Last edited by a moderator: Apr 20, 2011

    kristianmoss thread starter macrumors newbie

    Mar 17, 2011
    The OpenCV is a framework, the wxWidgets is not a framework, atleast I guess it is a dylib (if there is no other options for libraries then framework and dylib).

    I have tried adding OpenCV to the "Link Binary with Libraries" but I could not find the wxWidgets in there. and cv.h, is still an issue, meaning it doesn't seem to understand OpenCV framework.

    How do I add a dylib to Xcode?

    To be earnest I go through some Xcode tutorials, seems like I know so little about Xcode4 that I can't even ask questions that are good enough for you to be able to help me. (Like calling and ask for directions, when your not able to read the street signs). I'll probably be back

Share This Page