Opening applications on dock with a double-click?

Discussion in 'macOS' started by pedrolance, May 25, 2008.

  1. pedrolance macrumors newbie

    Joined:
    May 25, 2008
    #1
    Hi

    Sometimes when I'm working fast on my MacBook I click in the dock, opening applications that I don't want. This is a bit annoying to me, anyone knows how customize the dock in order it needs a double click to open the application - like is happens in the Applications folder?

    Thanks

    Helder Pedro
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    sorry cant be done. the items in the Dock are links to the original application like the quick launch bar in Windows.
     
  3. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #3
    Option

    Try setting the dock to automatically hide. Works for me on my 12" PB.
     
  4. pedrolance thread starter macrumors newbie

    Joined:
    May 25, 2008
    #4
    Ok, I will do that. Thanks.
     
  5. jtirish88 macrumors newbie

    Joined:
    Jan 22, 2009
    #5
    having the opposite problem

    when i open my apps it only takes one click to do so, but to switch between them once open i have to click twice on the icon in the dock. i cannot get rid of this. can anyone help?
     
  6. salmanrezai macrumors newbie

    Joined:
    Sep 30, 2010
    #6
    EXACTLY!!!! FINALLY!! SOMEONE WITH THE SAME PROBLEM!!! i have been experiencing the same problem as you dude. have you solved it somehow? please let me know. i find it very irritating to double click on on an icon. thanks in advance.
     
  7. Gregg2, Sep 30, 2010
    Last edited: Jul 6, 2013

    Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    Dude, that post is over 18 months old.

    /Users/YourUserName/Library/Preferences/com.apple.dock.plist

    Find that and drag it to your Desktop.
    Restart the computer.

    Wow, it will still let me edit this!
    Just wanted to say I don't know why I suggested this nearly three years ago now. I think that the behavior being described is normal.
     
  8. freeman906 macrumors newbie

    Joined:
    Jul 3, 2013
    #8
    Movin' Just keep Movin'

    what i did to solve the problem of the accidental clicks, was to move the doc to the right hand side of the page, it took an hour or so to get used to that but i never click an app open by accident now! probably saved a few minutes of my life closing apps. Result - HAPPY ME.
     
  9. kinley macrumors newbie

    kinley

    Joined:
    Nov 1, 2015
    Location:
    KZN
    #9
    1. Navigate to System Preferences
    2. Go to Mission Control
    3. Uncheck "When switching to an application, switch to a Space with open windows for the application"
     

Share This Page