opening iTunes causes Firefox to lock up/crash

Discussion in 'Mac Apps and Mac App Store' started by mikeM247, Oct 22, 2008.

  1. mikeM247 macrumors member

    Joined:
    Oct 20, 2008
    #1
    Hi. I'm really hoping someone can solve this problem for me, as it's been an issue since I bought this iMAC in early July. I went to the APPLE store, and they told me it's a Firefox issue. Here it goes: whenever I receive an email from "Apple Hot News" on my Apple Mail program, and there's a link to iTunes on it to, for example, check out a new artist's music or go to the iTunes store, I click on the link, and this causes the FF browser to immediately freeze up/crash, with a flood of tabs marching across the top of the screen, all saying "Untitled". I then have no choice but to quit Firefox, or manually turn off my iMAC if i'm not quick enough to quit the browser before it totally locks up. This only happens with the Firefox browser, and only with the iTunes site. This does not happen when I use Safari, Flock, etc, but I prefer using Firefox. I've tried uninstalling and re-installing the browser, hasn't made a difference. This was also an issue with my previous version of FF. i have the latest updated version, 3.0.3.

    I tried deleting the only cookie that was iTunes related, but that had no effect on the issue. TIA for anyone's help.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    I could absolutely be wrong on this, but here's a thought: have you tried opening iTunes before you click on the link? It sounds like FF is trying to launch iTunes to go to the store, but is having problems.
     
  3. mikeM247 thread starter macrumors member

    Joined:
    Oct 20, 2008
    #3
    TRUE, when i go to the iTunes icon on the dock and click on the icon, it ALWAYS opens up, no problem. So that =is= one workaround for sure, altho will it take me to whatever iTunes page i was trying to reach via the link in the Apple Mail? :confused:
     
  4. mikeM247 thread starter macrumors member

    Joined:
    Oct 20, 2008
    #4
    But it would still be nice to be able to resolve this issue I'm having with the browser. :(
     

Share This Page