Opening new tab slow in safari

coldwaves

macrumors 6502
Original poster
May 30, 2011
295
37
I upgraded to Mavericks. In Safari, when I click on a link and safari opens the link in a new tab, it is slow. There is a little lag when a new tag shows up in the tag bar. If I right click on the link and choose "open in new tab", there is no lag and the new tab opens immediately. I tried this on my friend's new 13 rMBP, it seems to be the same way. If the new link is opened in a new tab, there is always this small amount of lag. Do you have the same experience?

I have a early 2010 15 MBP with 2.0GHz CPU, 8GB RAM and 128G SSD.
 

Spie2

macrumors newbie
Oct 27, 2013
10
0
I'm experiencing the same with my MacBook Air with Mavericks. Because the tab isn't responding immediately, Safari opens two or three tabs after each other ... very annoying! It feels like a bug in Safari ...
 

coldwaves

macrumors 6502
Original poster
May 30, 2011
295
37
I'm experiencing the same with my MacBook Air with Mavericks. Because the tab isn't responding immediately, Safari opens two or three tabs after each other ... very annoying! It feels like a bug in Safari ...
I tried to clean reinstall Mavericks and it is still the same way. Hopefully it will be fixed in the updates.
 

stuffradio

macrumors 65816
Mar 17, 2009
1,015
6
I upgraded to Mavericks. In Safari, when I click on a link and safari opens the link in a new tab, it is slow. There is a little lag when a new tag shows up in the tag bar. If I right click on the link and choose "open in new tab", there is no lag and the new tab opens immediately. I tried this on my friend's new 13 rMBP, it seems to be the same way. If the new link is opened in a new tab, there is always this small amount of lag. Do you have the same experience?

I have a early 2010 15 MBP with 2.0GHz CPU, 8GB RAM and 128G SSD.
I don't have this issue. I have 16 GB ram, 2011 the middle Mac mini.
 

closet geek

macrumors member
May 31, 2007
39
3
I upgraded to Mavericks. In Safari, when I click on a link and safari opens the link in a new tab, it is slow. There is a little lag when a new tag shows up in the tag bar. If I right click on the link and choose "open in new tab", there is no lag and the new tab opens immediately. I tried this on my friend's new 13 rMBP, it seems to be the same way. If the new link is opened in a new tab, there is always this small amount of lag. Do you have the same experience?

I have a early 2010 15 MBP with 2.0GHz CPU, 8GB RAM and 128G SSD.
I see this as well. It happens with any link that has target="blank" and there is a noticeable pause/lag/delay before the new tab appears and loads the content. This can be worked around by holding down the cmd key when clicking the link or right clicking on the link and selecting "Open in New Tab" as you say. I would love to know what is causing this or if there are any workarounds.
 

coldwaves

macrumors 6502
Original poster
May 30, 2011
295
37
I see this as well. It happens with any link that has target="blank" and there is a noticeable pause/lag/delay before the new tab appears and loads the content. This can be worked around by holding down the cmd key when clicking the link or right clicking on the link and selecting "Open in New Tab" as you say. I would love to know what is causing this or if there are any workarounds.
Exactly. Thanks for letting me know. Hope Apple fixes this small issue in the future updates.
 

jimmyz80

macrumors member
Jun 12, 2012
68
5
Apex, NC
I'm experiencing this as well, but in a slightly different way. I normally hit command-t to open a new tab, and immediately begin typing the URL or search phrase I want to go to. The lag in Safari is making it drop the first few letters I type, so instead of "iPad pre order date", i'll end up going to "d pre order date". So frustrating to have to slow down for a cutting edge laptop. :/
 

estockme

macrumors regular
Mar 3, 2011
236
1
me too!!! i was switching to safari just for the icloud keychain... but now i'm missing the flexibility and security of lastpass anyhow, so maybe who cares.
 

xangria

macrumors newbie
Jul 22, 2013
5
0
I'm having the same problem. My MBP has 10 gb of ram, so it definitely shouldn't be lagging. Must be an unfortunate bug.
 

ZadloPL

macrumors newbie
May 18, 2008
7
0
Problem seems to be with Shared Links in the Side Bar hit ⌘⇧L that will hide the side bar and fix slow tab opening.
 

bociusz

macrumors newbie
Jul 16, 2012
3
0
Guys, here's the solution: turn off iCloud Safari sync, because tab syncing makes it slow (System Preferences > iCloud > Safari).
 

pentool

macrumors member
Jul 20, 2013
39
1
Interesting that I still find posts today (October 2017) where people complain about this issue. I'm one of them. I'm running El Crapitan 10.11.6 with Safari 11.0. I had this lag on Yosemite and El Crapitan as well. Turning off iCloud, etc did not solve it for me. What it was/is the AdBlock Pro extension. That's the only extension I have in Safari but seems to somehw interfering with opening new tabs. I also have my favorites listed in the dropdown list when you click in the address bar. That was slow as well. Took 2-3 seconds to have them drop down. All this issue has disappeared when I disabled AdBlock Plus. Will have to figure out a strategy to keep ABP but so that it will not interfere with tabs and favorite dropdown.