OPENSSH goes missing

Discussion in 'Jailbreaks and iOS Hacks' started by heisenberg123, Nov 26, 2010.

  1. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #1
    hello i was wondering if anyone else has had a similar issue as me, a few times now ive tried to WINSCP into my phone and it would not detect it so i would open my SB Settings to confirm SSH was toggled ON only to see the toggle was not even there, i would go to "more" within SBSettings and i under the set toggles it was on turning it off then on and respring does not bring it back i have to re-install OPEN SSH from cydia to get my toggle back

    im using SB Settings 3.2.1

    thanks
     
  2. The LPT macrumors regular

    Joined:
    Mar 8, 2010
    #2
    have you ever changed the default password?
    The toggle didn't start showing up until after I changed the default password.

    Also did you JB with pwnagetools? Limera1n? or Greenp0ison? I noticed that with pwnagetools it stopped working occasionally and i I had to keep reinstalling OpenSSH everytime I wanted to use it. Where as with Limera1n it I never had that problem.
     
  3. MrThompsonR macrumors 6502

    MrThompsonR

    Joined:
    Dec 15, 2009
    #3
    A little off topic, but I think a better option is using the sync cable and an app on you PC/ Mac to "SSH" into your phone... I avoid dropped WiFi connections in the middle of a transfer/ install on my phone. Some routers without warning randomly switch your ip address(unless setup with a "static" ip address), causing you to reconnect with a different ip address and start all over. Very frustrating... I use iFunBox or iPhoneBrowser to add mods to my iP4. I plug the sync cable and then close iTunes when it pops up. Then I open iFunBox and I'm into the phone.
     
  4. heisenberg123 thread starter macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    no i havnt changed the password, and i used greenp0ison
     
  5. az988, Nov 26, 2010
    Last edited: Nov 26, 2010

    az988 macrumors member

    Joined:
    Dec 26, 2009
    #5
    i've got the same problem with limera1n on v4.1 (iphone 4). I did change my ssh password, and when I use the mobileterminal on my iphone, i can connect to SSH through there. If I try to use putty from my windows machine, it cant establish a connection. I made sure that the wifi ip address is the same as well. I also installed afc2add. Any ideas?? Thanks!
     
  6. djbrotherson macrumors regular

    djbrotherson

    Joined:
    Jan 8, 2009
    #6
    I jb'd with jailbreakme.com. I'm still on 4.0.1 and my ssh toggle disappeared just like buddy up there. The toggle is still in "Set Toggles" in SBSettings 3.2.1 but doesn't show up regardless if it's on or off. It was working before so wtf??:confused:

    Is there no way to fix this?
     
  7. djbrotherson macrumors regular

    djbrotherson

    Joined:
    Jan 8, 2009

Share This Page