OpenSSH won't work after 2.1 update (with quickpwn)

Discussion in 'Jailbreaks and iOS Hacks' started by Salvacion, Sep 14, 2008.

  1. Salvacion macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Inglewood, CA
    #1
    I just updated my phone to 2.1 using quickpwn and I can't seem to be able to connect to my phone using terminal or Cyberduck. I've done it before, so I know there's nothing wrong in the process, at least I don't think. I keep getting "operation timed out" in terminal. I've installed openSSH through Cydia, and am trying to run the "ssh root@" command in terminal.

    I maybe looking too much into this problem and it will turn out to be something really simple and I'll feel dumb, however, I'll feel dumb and be able to FTP into my iPhone so I'll take the risk. If anyone has any ideas I'd appreciate it.

    Thanks in advance.
     
  2. quikadanquik macrumors member

    Joined:
    Jul 23, 2008
    #2
    is the IP correct?
    my ip changes sometimes

    on another note how did you get quickpwn to work?
    whenever i tried to run it it would transfer the files but my iphone would never install anything and would eventually turnoff and when i turned it back on it would be not jailbroken (i was able to use the new pwnage tool easily though)
     
  3. Salvacion thread starter macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Inglewood, CA
    #3
    It worked all of a sudden, don't know what was the problem, but whatever.

    You have to update your iPhone using iTunes first, so that you'll have an updated unjailbroken phone. Then you just run quickpwn and follow the instructions, after a reboot I had Cydia and Installer on the springboard. I usually use pwnage tool, but I was having some problems.
     
  4. bmwpowere36m3 macrumors 6502

    Joined:
    Nov 8, 2007
    #4
    Had the same problem with OpenSSH on my JB iPhone, I was using Fugu and it would connect. Kept getting a "REMOTE HOST CHANGED..."... after a few reboots of the iPhone and MBP all was good again.
     
  5. DravenGSX macrumors 6502a

    Joined:
    Aug 20, 2008
    #5
    This is the result of the host changing in the SSH Key that is saved in your SSH client on your computer. Delete your known_hosts keys and re-connect, a new key will be generated.
     
  6. iceburgdesigns macrumors newbie

    Joined:
    Sep 16, 2008
    #6
    im having the same exact problem, but deleting the known_host file doesnt solve it. i had my phone jailbroke on 2.0 and could ssh fine. now on 2.1 i can not get into it at all. i have tried everything! there has to be more people having this problem!
     
  7. Hls811 macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #7
    I'm having a similar problem - can someone tell me how to delete the known_hosts?? That might be what I need to do.
     
  8. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #8
    MAC OSX

    Open Finder > Press CMD+SHIFT+G > Type '.ssh' Press ENTER

    Delete file called known hosts here.
     
  9. Salvacion thread starter macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Inglewood, CA
    #9
    seems my problem is back. I was trying to ftp into my phone to change my SMS sound, and it wouldn't connect, I made sure that the IP address was correct, since it does change often, I'm on the universities internet. Also the problem is not with the host key, it just won't connect. Cyberduck says it can't connect and terminal says "operation timed out". Again, any ideas why this is hit or miss?
     

Share This Page