Opera 37

Discussion in 'Mac OS X Lion (10.7)' started by oldhifi, Mar 3, 2017.

  1. oldhifi macrumors 6502a

    oldhifi

    Joined:
    Jan 12, 2013
    Location:
    USA
    #1
    Started using Opera 37 on Lion 10.7.5, so many sites keep telling me to upgrade browser (Safari)
     
  2. oldhifi thread starter macrumors 6502a

    oldhifi

    Joined:
    Jan 12, 2013
    Location:
    USA
  3. camardelle macrumors 6502

    Joined:
    Aug 17, 2011
    Location:
    Texas
    #3
    There's a version of Firefox that will work with Thai oz version? I'm getting the "update" message all the time and getting to some of my secure sites need to be done on my MBA.
     

Share This Page