Opera Browser

Discussion in 'MacBook Pro' started by 06Honda, Dec 6, 2014.

  1. 06Honda macrumors regular

    Joined:
    May 25, 2011
    #1
    Which Opera Web Browser version will work on my 10.6.8 Snow Leopard macbook pro. Thanks.
     
  2. TOMIMOT macrumors 6502

    TOMIMOT

    Joined:
    Jul 16, 2011
    Location:
    Canada
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Current Opera version is 26, and requires 10.7 or higher.
    You can download version 25, which is OK with 10.6 or higher, from this page
    http://www.macupdate.com/app/mac/6297/opera
    Scroll partway down that page for the download link for ver 25.
     
  4. 06Honda, Dec 6, 2014
    Last edited: Dec 6, 2014

    06Honda thread starter macrumors regular

    Joined:
    May 25, 2011
    #4
    Everyone :) don't they. Some web sites I use daily don't load correctly on Safari Version 5.1.10 (6534.59.10). Can't update Safari due to being on Snow Leopard 10.6.8
     
  5. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #5
    Why in God's name would you use Opera and not Chrome? Chrome still supports 10.6.
     
  6. brdeveloper macrumors 68020

    brdeveloper

    Joined:
    Apr 21, 2010
    Location:
    Brasil
    #6
    He is not american. Opera is so Nokia'ish, and this is not an insult. Actually I like the euro look and feel of Opera.
     
  7. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    Because people prefer choice. Different strokes for different folks.
     
  8. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #8
    Why are you even on Snow Leopard?
     
  9. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #9
    Why not?

    The OP may not have a computer that can run a later OS, or he has not real need to upgrade. I've known people who choose to stick with a version, because they don't want the newer flavor.
     

Share This Page