Optibay disk ejects on sleep and won't stop spinning

Discussion in 'macOS' started by Exacerb8, Feb 24, 2010.

  1. Exacerb8 macrumors newbie

    Joined:
    Feb 6, 2010
    #1
    I replaced my superdisk with a 500 Gb Seagate drive in an optibay enclosure (unibody MBP running 10.6.2). The drive mounts fine on startup, and has not exhibited any unpredictable behavior in the file system, but it frequently ejects and provides me with this unhelpful message:
    The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off. To eject a disk, select it in the Finder and choose File . Eject. The next time you connect the disk, Mac OS X will attempt to repair any damage to the information on the disk.
    Once the drive ejects it is not visible in disk utility. I can hear it spinning continuously, but cannot access the drive. Moreover, I cannot access the drive unless I fully shut down the system and then reboot. A restart is often not sufficient to get the drive back up, but a full shutdown has worked every time so far.

    The behavior seems to happen when the computer sleeps. I noticed that it would also happen sometimes if I handled the computer roughly by setting it down jarringly, so I took the whole thing apart, and reseated the drive within the enclosure, but the drive still ejects frequently, about once per day.

    The only related behavior that I've seen documented in forums has been happening with USB external hard drives. I got the idea to disable the "put hard disks to sleep when possible" setting from one such forum, but this does not seem to have solved the problem.

    Any other ideas? I'm about ready to reinstall the superdrive, or to just replace the disk with a jell-o mold.
     
  2. davidded macrumors newbie

    Joined:
    Mar 31, 2010
    #2
    Confirmed: Lockup and Eject after Sleep with Optibay

    Hi Exacerb8,

    I have recently upgraded my MBP early 2007 (Core2) with an Optibay
    to use a SSD as startup / users disk, and my previous disk for large storage.

    The setup is as follows:
    Hard disk bay SATA: Kingston V+ 128GB SSD
    Optibay with PATA-> SATA bridge: Seagate Momentus 7200.4 G-Force 500GB, SATA II (ST9500420ASG)
    Snow Leopard 10.6.2

    Just as you described, after waking from sleep the disk spins up again but locks up the system with a timeout until the kernel finally forces an unclean unmount. I thought to have fixed it by disabling safe sleep (with hibernation),
    but then the issue appeared again after going off AC. Typically, the lockup happens every second time I sleep my Mac, and sleeping with the problem in progress makes it hang completely.

    Obviously, this is a really bad thing. Even worse is that it seems to be a rare (?) problem, so I would like to track it down.
    Could it be related to the diverse issues people are having with this particular Seagate disk, which concerns power management?

    Interestingly, you a unibody, and I have not. This means that the problem is likely not caused by the PATA->SATA bridge in my optibay, as you have a direct SATA connection.

    Please feel free to contact me,
    it would be nice to track this down together.

    Regards,
    -David.
     
  3. Exacerb8 thread starter macrumors newbie

    Joined:
    Feb 6, 2010
    #3
    Perhaps I am not alone

    It sounds like your symptoms are just like mine. My favorite part of this story is when it refuses to hibernate and I accidentally put it in my computer bag without fully shutting it down, and then it almost causes a meltdown.

    My seagate drive is slightly different than yours:
    5400.6 ST9500325AS
    But I agree that the bridge would seem not to be the problem. I've also disassembled my computer one more time and put additional foam tape around the drive enclosure to keep it from moving, but that is clearly not the problem.

    I'm all ears for ideas on this. I guess that one of us should buy a non-seagate drive, clone the disk onto it, and see if the problem stops occurring. Do you have a better diagnostic in mind? Some drives have a jumper to disable an energy saving function, but I looked at mine and didn't find a selector.
     
  4. davidded macrumors newbie

    Joined:
    Mar 31, 2010
    #4
    No problems so far with WD disk and Optibay

    Hi,

    said and done - to isolate the issue I today bought a WD6400BEVT disk.
    It spins only with 5400 rpm but is fast enough as a secondary disk besides the SSD and also much quieter (less vibration) than the Seagate.

    After the usual tedious disassembly I am now running my MBP with open case on my desk - so far without any problems.
    I have had the Mac sleep frequently and then wake it up after different time intervals - both short and long. I also tried different sleep modes, with and without hibernate.

    So far I have not experienced a single hang with that configuration. To test the setup, I tried to browse and write files on the optibay disk right after waking the machine, sometimes waiting a bit, sometimes at once.

    It would be interesting to see if replacing the drive helps you as well, and if the pleasure lasts.

    Regards,
    -David.
     
  5. Exacerb8 thread starter macrumors newbie

    Joined:
    Feb 6, 2010
    #5
    Not 5400 RPM

    Well, it can't be the spin speed that is causing the problem because my Seagate drive spins at 5400 RPM. It will be a couple weeks until I can upgrade the drive. Let me know if the drive upgrade stops working. I'll be in touch when I have a new drive installed.
     
  6. Sebastianmonty macrumors newbie

    Joined:
    Jul 3, 2008
    #6
    Hey David, a week has passed. Any problems thus far? I have an optibay in the mail and will put in my HD as soon as it's delivered. I will have my itunes library and pictures and downloads and documents on it so I don;t want it to hang. However I have a UMBP and a Fujitsu 500Gb 5400
     
  7. johngwheeler macrumors 6502

    Joined:
    Dec 30, 2010
    Location:
    I come from a land down-under...
    #7
    I too have had a problem with the Optibay HDD ejecting after making my 2007 MBP from sleep. The drive is a Seagate 500GB 7200rpm.

    I get the following entries in the System console:

    31/12/10 10:07:57 AM kernel IOATAController device blocking bus.
    31/12/10 10:08:31 AM kernel IOATAController device blocking bus.
    31/12/10 10:09:06 AM kernel IOATAController device blocking bus.
    31/12/10 10:09:40 AM kernel IOATAController device blocking bus.
    31/12/10 10:09:40 AM kernel ATA: Device recovery failed (0x00000003), terminating device...
    31/12/10 10:09:40 AM kernel disk1s3: I/O timeout.
    31/12/10 10:09:40 AM kernel
    31/12/10 10:09:40 AM kernel disk1s3] [MountPt /Volumes/MacData] [FSLogMsgID 1157588846] [FSLogMsgOrder Last]
    31/12/10 10:09:40 AM kernel disk1s3: media is not present.

    So it looks like the ATA controller gets locked up somehow after waking from sleep, forcing the system to eject the disk.

    I've written to MCE, but would be very interested if anyone has found a solution to this problem.

    Thanks,

    John
     
  8. pereinar macrumors newbie

    Joined:
    Jan 8, 2011
    #8

    I had the same issue with one of the drives mentioned in this thread (Seagate ST9500325AS) but mine was running in an Optibay equivalent purchased on Ebay(Fenvi 2nd HDD caddy Macbook pro OptiBay SuperDrive PATA 9.5mm). I'm using a Kingston 2.5 inch 96GB SSDNow V+100. I have a late 2007 MacbookPro 2.2Ghz (Santa Rosa).

    Today I decided to replace the Seagate with my Stock FUJITSU MHY2120BH 120GB. So far so good. I'm not seeing any of the problems I had with the Seagate. I would like more capacity though, so if there's anyone out there who has had this issue with the mentioned Seagate drive(s), what replacement drives have worked for you?

    I will follow up if I have any issues with my current configuration.
    By the way, my Fujitsu is a SATA 1.5 device. Don't know if that could make a difference. I doubt it though.
     
  9. pereinar, Jan 9, 2011
    Last edited: Jan 9, 2011

    pereinar macrumors newbie

    Joined:
    Jan 8, 2011
    #9
    Follow up

    I was getting the same "IOATAController device blocking bus" messages with my seagate ST9500325AS in my optibay equivalent (see above post). Things have worked fine after replacing it with my stock FUJITSU MHY2120BH for over 24 hours now. I have put the machine to sleep and restarted it several times without issue. Please note, my ST9500325AS also works fine in an external esata enclosure so this is not a bad drive. I'll keep running with the Fujitsu in the optibay for a while. 120 GB is a bit low for my taste so I will probably purchase a non-Seagate 500GB or 750GB sooner or later. Again, I would appreciate any experiences from anyone else who has remedied this issue by using a switching drives in the optibay. What drives work, what drives don't?
     
  10. pereinar macrumors newbie

    Joined:
    Jan 8, 2011
    #10
    So, here is what I have learned in summary: Please note I am using a fenvi caddy (not optibay). It runs on the ATA bus in my 2007 MBP Santa Rosa. The caddy has a converter from ATA to SATA.

    Kingston 2.5 inch 96GB SSDNow V+100 w/ Seagate ST9500325AS in caddy = FAIL! ( I have read about other people with the same drive with the same issues of spontaneous ejection of the drive)
    Kingston 2.5 inch 96GB SSDNow V+100 w/ stock FUJITSU MHY2120BH in caddy. = SUCCESS for over two weeks now.
    Kingston 2.5 inch 96GB SSDNow V+100 w/ Western Digital WDC WD5000BEKT in caddy = SUCCESS. As of today I finally upgraded to this 7200 RPM 500GB. Even on ATA this drive is a fair bit faster than my stock 5400 rpm FUJITSU.

    I guess the ATA bus has issues with certain drives. Not to discredit all Seagate drives, but in my experience so far FUJITSU's and Western Digitals run great on this setup.
     
  11. kirkwhite macrumors newbie

    Joined:
    Jan 30, 2011
    #11
    SSD in Fenvi

    Any reason that you could not put a SSD in the Fenvi? Not so much worried about speed as I want a machine that is acoustically quiet as possible.
     
  12. pereinar macrumors newbie

    Joined:
    Jan 8, 2011
    #12
    Should work fine. Just set it as your startup disk (or hold option when booting) and you should be good to go.

    As far as noise goes the drive I'm using is fairly quiet (WD5000BEKT). However, I have set the drive to go to sleep after 7 minutes (vs 20 min default) to conserve battery and reduce the noise a bit.
    Type: sudo pmset -g to view your current settings.
    Type: sudo pmset -a disksleep 7 to set the drive to sleep after 7 minutes of inactivity.
     

Share This Page