Optibay partitioning problem, met with dead end

Discussion in 'MacBook Pro' started by Prodo123, Dec 1, 2013.

  1. Prodo123, Dec 1, 2013
    Last edited: Dec 1, 2013

    Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #1
    Hello,

    I run an Early 2011 15" MBP with the revised 2.2Ghz i7. It has SATA-III unlocked but doesn't support it well in the optical slot.

    I got a Samsung 840 EVO 250GB off of Amazon during Black Friday (hehe discounts)! Got it 10 days (!!) early and now everything is installed. Pretty much nothing went wrong with the installation. The hard drive is a Seagate Momentus XT Gen 2 750GB (SATA-III drive).

    At first I kept the hard drive in its caddy and put the SSD in the optibay. Of course when I tried to format it I came across trouble with the error "Wiping volume data to prevent future accidental probing failed." Verification/repair resulted in more or less the same error. Eventually I used iPartition to somehow format the drive but the resulting partition was stuck in read-only mode with no way to install anything. Any attempts to write to the drive resulted in a Finder -50 error. Not good.

    Thinking it was the SATA-III issue, I swapped the two drives so that the SSD was in the hard drive caddy. I did a test run by booting the computer without the SSD installed, i.e. booting from the HDD in the optibay. It worked, although I noticed it took 30 times longer than usual (no exaggeration). The hard drive had read/write capabilities, no errors, and pretty much worked fine.

    I booted then to the hard drive's recovery partition (which seems to be completely unaffected by any of these issues). Installing Mavericks went swimmingly and the computer booted up in 6 seconds flat. I was also able to migrate most of my user data from the HDD to the SSD, only the stuff that counted anyway. But during the transfer some corruption seemed to have occurred as I can no longer run Ableton and uTorrent.

    I tried to write a file to the hard drive, but the -50 error occurred again. Went to Disk Utility, ran verify. Partition itself came up as fine but the disk resulted in a missing EFI partition. The hard drive was also no longer bootable. So I tried to repartition the entire drive, and guess what! The error message "Wiping volume data to prevent future accidental probing failed" came up again! Attempts to simply erase the partition returns with "MediaKit reports not enough space on device for requested operation" which is just "You're SOL" in nice terms. Tried using iPartition and it was able to wipe the drive and put a proper GPT on it, but any attempts to partition the disk fails.

    I checked every cable and connection to make sure it's not that. I also know both drives are in working condition since I've been running from one for a year and am typing from the other. The optical bay SATA cable seems to be fine as well.

    What do you think is the problem here? Maybe it's because the hard drive is SATA-III, or is it some faulty cabling within the optibay? Please someone help > <

    P.S. Yes I've been Googling for solutions for the past 5 hours and none of them seem to help in any way. Most of them either have no answer or direct toward a faulty cable of some sort. I've tried SMC resets, NVRAM reset (which I think caused the EFI partition corruption in the first place) and the things listed above. I did see the suggestion that the SATA connector might be faulty, but I find that unlikely especially since the hard drive was able to boot fine from the optibay...
     
  2. Prodo123 thread starter macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #2
    I just tested my old hard drive which is SATA-II max. It runs fine!
    So it indeed is a SATA-III problem. Which is an issues once I have no idea how to limit the link speed for the Momentus XT gen 2. Apparently no jumper settings work...
    Is there a way to force a SATA link speed for a specific SATA port in OS X?
     

Share This Page