Optical Digital-out Port problem

Discussion in 'MacBook Pro' started by mtnsaray, Jul 11, 2011.

  1. mtnsaray macrumors newbie

    Joined:
    Jul 11, 2011
    #1
    Hi guys,

    recently i was using my logitech speakers with my macbook pro. After i unplug it, the jack was still in red light and i recently did the toothpick trick...

    Even though the red light goes off, my sound icon is gray and my system pref still says the same thing "optical digital .. .. "

    How can i solve this issue? Would formatting the macbook pro work?

    im out of warranty and it's not a hardware problem, because i can hear the startup sound from the inline speakers..

    Thanks in advance
     
  2. mtnsaray thread starter macrumors newbie

    Joined:
    Jul 11, 2011
  3. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #3
    Have you rebooted since "turning off" optical digital output? If you have and that didn't help, try this:

    Try Resetting your Mac's PRAM and NVRAM, if that doesn't work, try this:

    Move the com.apple.soundpref.plist from your User/Library/Preferences folder to the Desktop, reboot and a new one should be recreated and you'll have to reset your audio preferences.

    When it comes to Macs, formatting and reinstalling is/should only be used as a last resort.
     
  4. mtnsaray thread starter macrumors newbie

    Joined:
    Jul 11, 2011
    #4
    Thanks for the advice, i tried what you said, the soundpref file recreated itself but still no sound and gray icon..

    In the sound output i cant see the inline speakers, just the digital out..

    And i can still hear the startup voice of the OS...

    Hoping it's not a hardware issue...

    If there's more advice i am listening,

    otherwise thanks again.
     
  5. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #5
    Try checking Audio MIDI Setup in your Utilities folder in the Applications folder. Maybe something under Built-in Output.
     
  6. mtnsaray thread starter macrumors newbie

    Joined:
    Jul 11, 2011
    #6
    I've checked the Audio MIDI Setup and Source:Digital Out is the only option there in the drop-down menu. and Volumes are at minimum and cant controllable..

    It's like it just sees the Digital Out-port and no inline speakers as known in the machine..
     
  7. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #7
    How about trying this:

    :apple: Resetting your Mac's PRAM and NVRAM
     
  8. mtnsaray thread starter macrumors newbie

    Joined:
    Jul 11, 2011
    #8
    Just did that and no luck, and no red light too, but still says Digital-out port and no inline speakers.. but can hear the voice still at the beginning
     
  9. mtnsaray thread starter macrumors newbie

    Joined:
    Jul 11, 2011
    #9
  10. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #10
    I don't have any personal experience with this problem but from what I've read of it on the net, getting the light to go out usually switches it back to analog and sound is restored. Seems like you've managed to somehow get the light to go out but not actually switch it back to analog.

    The only other thing I can think of is to plug the digital optical cable back in and see if you can get it to work properly. Or maybe plugging in a headphone plug, etc. might also work. May take multiple tries.
     
  11. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #11
    Your issue sounds mechanical - even with mini TOSLINK inserted to a functioning jack - my Macs (all of them) always had a startup chime on the internal speakers.

    My 2006 iMac has a bad jack, straight after warranty was up, and it's soldered / shielded directly to the motherboard - I'm solder certified / trained - and even I wasn't about to touch this thing. New mainboard costs nearly as much as this iMac did brand new - so that option was out. I ended up setting it for permanent optical digital output - and epoxied the connector on the outside so it will not even twitch.

    But yeah, sounds like the switch / contact that detects you have the optical cable is the culprit.

    Edit - the update issue I recall was resolved via firmware update or patch - but if you haven't swapped OS's recently - I'm doubting this is the cause. Do you have any other OS / bootcamp on that? That could rule out OS.

    FYI the switch that detects the optical is common to the headphones - the plugs have the same profile, however headphones will conduct - where the optical does not - but there are two triggers. Jack inserted, then optical / vs electrical. If the light is out, try flipping your audio up / down via keyboard or IR remote - if it shows the volume control with a "no" symbol going through it - it still thinks you're running optical. If it shows volume going up / down - then it likely thinks you have standard headphones plugged in.
     
  12. guruleroger macrumors newbie

    Joined:
    Apr 18, 2014
    #12
    Cool work-around

    So I have had this problem for a few weeks now and NOTHING suggested has worked to get things back to normal.

    But just today, I stumbled upon a cool little work-around.

    Go to your Sound settings in System Preferences and set 'Use audio port for:' to 'Sound Input'. Now plug headphones into your headphone jack, and 'Internal Speakers' should be available!

    It doesn't really fix the problem; and every time you want to hear your internal speakers, you'll need to have headphones plugged in (TOTALLY counter-intuitive lol), but at least you'll have access to them!

    Hope it works for you!

    -Roger
     
  13. mkhan11 macrumors newbie

    Joined:
    Jun 16, 2014
    #13
    Optical digital-out port

    I have been dealing with the same problem. I am confident that it is not a hardware issue. I have windows running in the mac and the speakers are working just fine. Unfortunately on the mac OS the Sound Output is shown as Optical digital-out port. When headphones are plugged in, it works just fine.

    I have installed a new version of the OS and I have reset the PRAM. No dice.
    Any help will be appreciated.
     

Share This Page