Optical Drive not showing in Finder/Disk Utility (fails to eject) for 2008 Mac Pro

Discussion in 'Mac Pro' started by xSinghx, Feb 13, 2015.

  1. xSinghx Suspended

    xSinghx

    Joined:
    Oct 2, 2012
    #1
    Recently both drives on my 2008 Mac Pro fail to eject. Pushing the eject buttons triggers a sound as if something is trying to eject but holding down the flap on the front of the drive shows no movement.

    Both drives are greyed out when I open disk utility to try to eject from there. I've tried all of the standard stuff, ejecting from the top bar, rebooting holding down the mouse, unplugging everything and rebooting. Nothing seems to work and I'm becoming increasingly frustrated. The drives won't open on the other user account I have setup either (both accounts are admin) and even win7 which is installed on a separate drive will not open the drives when using bootcamp.
     
  2. nigelbb macrumors 6502a

    Joined:
    Dec 22, 2012
    #2
    When you say "unplugging everything and rebooting" I presume that you mean just the power cord. These drives do fail but first off you need to open up the case & unplug & replug the power & ATA connector on the drive itself.
     
  3. xSinghx thread starter Suspended

    xSinghx

    Joined:
    Oct 2, 2012
    #3
    Hi nigel,

    Initially I unplugged everything from the back. If I recall this resets a few things like the pram, but like I said it had no effect.

    I've since tried what you suggested but came into a road block on the internal power connector. The ATA connector is easy enough to take off however the power is not. There are slight bumps on the sides of the connector (I'm not sure if they have to be squeezed), I was fairly forceful and could not get it to come off. I'm not sure if there is a trick. From the video's I researched it looks like they switched to a different type of connector with the 2009 models and none of the youtube vids seem to have a problem disconnecting a drive's power. Any tips?

    I've put it all back together and still the drives don't show in disk utility and will not open - just giving the same sound as if they're blocked.

    From the research I've done, it seems apple has history of having software issues with the drives believing something is using them. I've always had this kind of problem occasionally. Usually closing all programs or simply restarting my computer fixed it but was never ongoing like this.

    Thanks for the input.
     
  4. adam9c1 macrumors 65816

    adam9c1

    Joined:
    May 2, 2012
    Location:
    Chicagoland
    #4
    Do the drives get power?
    Can you take them out and plug in to another computer SATA power port to test if trays will open?
     
  5. Machines macrumors 6502

    Machines

    Joined:
    Jan 23, 2015
    Location:
    Fox River Valley , Illinois
    #5
    PRAM your Mac by pressing the Command-Option-P-R keys at the same time when your Mac starts up . Release keys after second chime . Attempt to eject optical trays now .

    If that doesn't work , try Target Disk mode by pressing the T key at start up and then hitting the eject key on an Apple keyboard .

    Possibly, both your drives are shot . You might want to verify this by installing a replacement IDE optical drive that is known to work .
     

Share This Page