Optimizing Leopard for G4 systems

Discussion in 'PowerPC Macs' started by ptdebate, Feb 10, 2015.

  1. ptdebate macrumors 6502

    ptdebate

    Joined:
    Jul 3, 2014
    Location:
    Dallas, Texas
    #1
    Hi all,

    I did a search and was unable to find a topic directly addressing this, but please correct me if I'm wrong.

    This is more-or-less directed towards a particular user (you know who you are :D) but I wanted to find out how to improve Leopard performance on my G4 tower by disabling some graphical features. Performance is great as it is, but when running multiple programs there is a performance hit and window animations chug occasionally.
     
  2. Xernicus macrumors member

    Joined:
    Jan 25, 2015
    Location:
    Seattle, WA, USA
    #2
    Turning off the dashboard helps quite a bit, by typing the following into the console:
    Code:
    defaults write com.apple.dashboard mcx-disabled -boolean YES
    and then
    Code:
    killall Dock
    You can also turn off Spotlight. However, I find Spotlight very useful, so I can't personally recommend this unless you're running Leopard on an unsupported G4, or if you have a 4200RPM hard drive. It has been reported that disabling Spotlight will affect Time Machine, so don't turn it off if you use Time Machine.

    Some more terminal commands:
    Code:
    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
    followed by
    Code:
    sudo launchctl unload -w /System/Library/LaunchAgents/com.apple.Spotlight.plist
    If you've got a video card capable of Core Image, you can turn off the Transparent menu bar via the "Desktop and Screen Savers" Control Panel, which should help a little bit as well.
     
  3. MatthewLTL macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #3
    I have already done all that. However I used Onyx to do that. I see you guys mentioned nothing about turning off the 3D Dock.
     
  4. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #5
    Use an app called ShadowKiller. There is a noticeable speed gain if you have it run when you log in.
     
  5. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #6
    ^^^ I use this, even on my Intel Mac at work. What it does, if you do not know, is kills the drop shadows on all windows systemwide (all apps).

    For Finder windows this may be somewhat confusing because two or more windows can run together. It takes some adjustment, but it's worth it. I use it on all of my Macs.

    Run the app again if you want drop shadows back.
     
  6. MatthewLTL macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #7
    Believe it or not but I have tried these steps listed for speeding up Leopard. I have noticed SOME difference (such as turning off 3D Dock makes programs open faster) but when the 1GB of RAM Died in my eMac (Still in the machine) and it only is running off 512MB RAM The machine dont run any slower even though its operating on 1GB less RAM. Go Figure
     
  7. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #8
  8. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #9
    There's really no need to go through the web archive.

    A simple Google search for Shadow Killer reveals that it's still out there.

    Here's a Softpedia link. There are others.

    Yes, yes it does. I'm using it on 10.10.2.
     
  9. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #10
    Disabling BeamSync has helped with the animations a lot. It should not be disabled on CRT displays though.
     
  10. jbarley, Feb 16, 2015
    Last edited: Feb 17, 2015

    jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #11
    I also use ShadowKiller, one thing I notice is that it will not remove the drop shadow from the main top Apple menubar.
    Can anyone else confirm this for me?
     
  11. MatthewLTL macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #12
    ShadowKiller don't even open on my eMac it bounces twice and just closes out
     
  12. G4fanboy macrumors regular

    Joined:
    Mar 9, 2013
    Location:
    Andalucia Spain
    #13
    You never see shadowkiller app running. Just the GUI without shadows around the windows. Or with the shadows. Click on ShadowKiller is an on/off switch for the shadows on the GUI.
     
  13. MysticCow macrumors 6502a

    MysticCow

    Joined:
    May 27, 2013
    #14
    It auto closes. Check and see if the drop shadow is present on your windows. The title bar has its own shadow that cannot be disabled. ShadowKiller is working properly if it auto-closes.
     

Share This Page