option + command + d is broken [dock hiding], help?

Discussion in 'Mac Basics and Help' started by desenso, Sep 17, 2007.

  1. desenso macrumors 6502a

    desenso

    Joined:
    May 25, 2005
    #1
    Hi guys,

    So every once in a while this happens, and I have no clue how I fixed it in the past. I fear it might have been when I formatted.

    PROBLEM: the dock hiding / unhiding keyboard shortcut, option + command + d, is not working.

    WHAT HAPPENS: when I hit the key combination, the dock pops up momentarily but immediately goes back down. If I hold down the key combination the dock stays visible, until I let go of the keyboard, at which point the dock hides again.

    ATTEMPTED SOLUTIONS: Obviously I've tried a full power cycle. I've run cocktail to try and clean out any small issues with the system. I don't know what else to try.

    Anyone had this problem? Anyone know of a solution?
     
  2. appleachian macrumors newbie

    appleachian

    Joined:
    Sep 17, 2007
    #2
    Strange issue. Are you sure one of your keys isn't sticking when you're pressing it? If not, try to create another user account, and see if the problem persists.
     
  3. desenso thread starter macrumors 6502a

    desenso

    Joined:
    May 25, 2005
    #3
    Sadly it's not a sticky key because it happens with either the laptop keyboard, or with a USB keyboard. I'll try making a new account later today and see if that solves the problem.
     
  4. desenso thread starter macrumors 6502a

    desenso

    Joined:
    May 25, 2005
    #4
    I made a fresh account this morning. Lo and behold, the key combination works.

    So I've run every repair / system cleaning tool that I own, restarted numerous times, power cycled, moved the dock back to its default location, etc. Nothing seems to repair it, every time I hit the key combination the dock momentarily pops up and then goes back down.

    Anyone got any ideas?
     
  5. desenso thread starter macrumors 6502a

    desenso

    Joined:
    May 25, 2005
    #5
    SOLUTION: Hmm... I quit applications 1 by 1 that I had open. Turns out that it was TextExpander causing this. Now I have to figure out a way to both keep TextExpander running without causing this problem because I rely on this keyboard shortcut a lot!

    Just thought I'd post this in case anyone searches the forums looking for a solution to the same problem.
     

Share This Page