Orico USB 3 Card not working

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
Hi guys i have Orico USB 3 Card with 4 usb ports for mac that come with power connection manual say that the card does not need extra power but its not working. I am looking to power the ccard with free HD bay will this cable work in my case
6" 4 Pin Molex to SATA Power Cable Adapter SATAPOWADAP

Thanks

And can you recomend cheap mac pro 2009 usb 3 card


[doublepost=1489908268][/doublepost]I am ruining el capitan
 

Attachments

bax2003

macrumors 6502a
Dec 25, 2011
903
139
Serbia
Test it in a PC and if its working fine there, look for problem on your Mac - slot or some driver leftovers (CalDigit for example).
 

h9826790

macrumors G5
Apr 3, 2014
14,240
6,843
Hong Kong
I may have that card (PME-4U?), it need power. Only the 2 ports card that can run without extra power.

The picture is not very clear, but doesn't looks like the correct one to me. The cable require a STAT port that same as the one that on the HDD / SSD (can see the golden pins).

The card should run flawlessly once you prosper it properly.
 

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
Hi guys card works fine i was using it in my pc with power cable but i think i might need power and no drivers wore used before on my mac for any usb 3.0 what about this cable.
15 Pin SATA Male to 4 Pin Female Power Cable
 

Attachments

h9826790

macrumors G5
Apr 3, 2014
14,240
6,843
Hong Kong
Hi guys card works fine i was using it in my pc with power cable but i think i might need power and no drivers wore used before on my mac for any usb 3.0 what about this cable.
15 Pin SATA Male to 4 Pin Female Power Cable
The SATA port on this cable looks good to me, but you have to cut the plastic latch by yourself, otherwise it can't fit in the logic board's SATA port.

Couldn't remember what the other side looks like (the Molex side), but you have the card on hand, so it can't go wrong.

And no driver required for this card.
 

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
yeah no luch i biut the cable but when i tun on my usb 3 hub with ssd inside it nothing show up on mac
 

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
hm i i am seeing it in usb buss tree and i put my mac to sleep wake mac up and it was showing but after removing the ssd from orico bay and putting it back in powering it on it shows nothing on desktop i wonder if i should just buy new one without power cable
 

h9826790

macrumors G5
Apr 3, 2014
14,240
6,843
Hong Kong
hm i i am seeing it in usb buss tree and i put my mac to sleep wake mac up and it was showing but after removing the ssd from orico bay and putting it back in powering it on it shows nothing on desktop i wonder if i should just buy new one without power cable
In my own experience, that's nothing to do with the card (in fact, change to KT-4004 make situation worse). I had similar issue before (also from an Orico enclosure). I still can't figure out 100% the reason. But the fix is simple, connect the enclosure via a USB 3.0 hub (in my case, that's a Ocico hub as well). Then the connection suddenly become 100% stable.
 
Last edited:

JoSch

macrumors 6502
Feb 22, 2013
319
101
I used a Y-cable on one of the molex in the optical drive bay (3,1 still has them). Then from the Y-cable, I used an one meter long extension cord to the USB card.
 

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
Hi guys thanks for all the help i have used this program i dont know the name of it it used by hackintosh community where you drag drivers in to and apparently it installs it for you before that it did bunch of things to my mac like full file access ect i think i will reformat my mac and do clean install and see if that will recognize the card. I used GenericUSBXHCI_1.2.7.drivers and one from orico but i am not sure how to install them there is a file that look like a box but when i click on it it just say chose a program to use where do you drop it which folder its not auto install

Thanks guys
 

h9826790

macrumors G5
Apr 3, 2014
14,240
6,843
Hong Kong
Hi guys thanks for all the help i have used this program i dont know the name of it it used by hackintosh community where you drag drivers in to and apparently it installs it for you before that it did bunch of things to my mac like full file access ect i think i will reformat my mac and do clean install and see if that will recognize the card. I used GenericUSBXHCI_1.2.7.drivers and one from orico but i am not sure how to install them there is a file that look like a box but when i click on it it just say chose a program to use where do you drop it which folder its not auto install

Thanks guys
If you really have the correct "for Mac" card, should be no driver required under El Capitan.
 

enny001

macrumors member
Original poster
Apr 30, 2013
77
0
Hi guys this is the card i have PVU3-4P-R2.0

**** i don't think its supported. now i remember Me as morth i bought mac one but returned that one and got pc

Supported SystemWindows 10 / 8 / 7 / Vista / XP

http://orico.cc/goods.php?id=4785
[doublepost=1490069030][/doublepost]Thanks guys for all your help.

PS can you recommend a card just 2 usb 3 ports for my mac under El Capitan

I am looking at
Inateck Inateck 4 Ports PCI-E to Interface USB 3.0 Expansion Card for Mac Pro
 

Attachments

pastrychef

macrumors 601
Sep 15, 2006
4,520
1,027
New York City, NY
That looks like it's a VIA controller. As far as I know, it's not supported by macOS.

That driver you found may make it work... But I don't know how good that driver is or if it causes problems with anything else.

You are probably much better off going with an FL1100 based card that doesn't need any hacked drivers.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.