original file not found -can't do all of them!

Discussion in 'iPod' started by whyrichard, Apr 10, 2007.

  1. whyrichard macrumors 68000

    Joined:
    Aug 15, 2002
    #1
    why does my itunes (windows) keep on loosing track of songs?!?!?!?!
    the songs are where they should be!

    "could not be used because the original file could not be found"


    -KEEPS ON HAPPENING!

    too many songs, have to manually reselect each song?! -impossible!


    help!
     
  2. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #2
    Did you re-name any folders in the tree your music folder lives in? This only happens if you move the files from where iTunes expects them to be.
     
  3. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #3
    haven't changed a thing.

    these are songs imported just days ago!

    currupt library file?

    r.
     
  4. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #4
    Have you tried using the refresh (or is it update -- not at the mac right now) button in the lower right? That usually works for me.
     
  5. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #5
    Did you import them from an external device, and perhaps have it specified to not actually copy the songs from the device to your local library?
     
  6. whyrichard thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #6
    there is a reset button on the lower right? i see no other buttons then: speaker, view, and eject...


    ...and i have imported them from an external source, and it was set to copy to the itunes folder, and the files themselves are actually there, i've checked. i can manually 'remind' itunes that they are there, but i can't do it for each and every one... itunes forgot the location of too many songs!

    thanks,


    r.
     
  7. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #7
    Are these the ones that come up with a little exclamation mark?

    Seems to happen when a library gets over a certain size. I get it all the time. At first I thought it happened because I was running it off my external drive; but even after moving the whole library to another drive on my Mac Pro these "orphans" keep popping up.

    Yes, it is a pain to right click and get info and then manually select the "missing" file. In previous versions of iTunes it would actually track any other "missing" tracks in a given playlist, but I think after 6.0 you have to go an search for each one.

     
  8. alanyukfoo macrumors newbie

    Joined:
    Sep 26, 2007
  9. alanyukfoo macrumors newbie

    Joined:
    Sep 26, 2007
    #9
    exclamation marks on songs

    Try using the latest library from the 'previous itunes libraries' folder. Worked for me, I had broken links all of a sudden to 4000 songs. You can drag and drop it from that folder into the iTunes folder.
     

Share This Page