original G3 PowerBook won't detect internal modem

Discussion in 'Apple Collectors' started by Aeronautical, Aug 31, 2005.

  1. Aeronautical macrumors member

    May 8, 2005
    Hi, I'm still on about my powerbook (kanga/3500), managed to get it up and running with a nice clean os (9.1). The only thing spoiling it is that the system profiler won't detect the internal modem. The modem and ethernet are combined on one internal card (the same port at the back is used for both) and the ethernet is working perfectly.

    Using the system profiler it says "no apple modem detected". I've heard about a way to reset the modem using Appleworks 5 although haven't been able to try this yet. Does anybody know wether resetting can make a previously undetectable modem appear? Is there a way to physically check the connections/leads of my modem by opening up the powerbook? Or if the ethernet works does that mean all connections on that card are ok?

    I've also bought a Dayna Communicard pcmcia 33.6k modem card (from the same time period as the pb) and tried using it. That is detected by the powerbook/operating system as being inserted in the card slot (icon comes onto desktop) but its not showing up on the system profiler, so it won't dial up. So that's another problem there. If I thought it would work I think I would just buy a cheap 56k modem card, which would be faste than the internal one anyway.

    The main reason I want to get this pb on the net is to use the software update function. I'm afraid there may be some crucial Apple updates I'm msising out on for 9.1!

  2. 5300cs macrumors 68000


    Nov 24, 2002
    I have a Kanga, too (love it ;) )

    That's really strange that the internal modem isn't showing up. Are you sure it's not busted or something? Dumb idea maybe, but have you tried reinstalling OS 9 with all the fixin's?

    If you want to open the Kanga up, it's actually not too tough. It's just like the PB5300. Pulling apart the palm rest and all that can be a pain, though.

    As for the card modem, did you install drivers? I have an PCMCIA ethernet card that when inserted shows an icon too. Without the drivers though, it wouldn't work.

    Hope that helps ...
  3. RacerX macrumors 65832

    Aug 2, 2004
    Is the 3400/G3 modem extension installed?

    If not, you can get it here.

    I can't tell if this was a joke or not (no smilies), so if it wasn't...

    There are no crucial Mac OS 9.1 updates (even 9.2.1 and 9.2.2 were meant as optional for those using them as Classic in Mac OS X... though some software makers made those required). Apple didn't patch the older Mac OS like it has Mac OS X. So I wouldn't worry about it.

    If you really need to download something for your system, you could always install iTunes. It is not crucial, but is a nice addition.
  4. Aeronautical thread starter macrumors member

    May 8, 2005
    Hi 5300cs. I have reinstalled OS 9 a couple of times. I'm not certain that the modem isn't just dead. If all else fails I think I will have to open it up.

    As for the modem card- I don't think I did install drivers. Call me stupid (and I probably am on this point!) but I couldn't identify on the disc what I really needed to install. There was a list of files labeled 'install 1, 2, 3, 4'. I went to install the first one and it was an older version of Open Talk (or Open Transport?) than my system already had. Perhaps I should have continued thru the list and tried installing the other files. I think the modem icon showing up on the sesktop led me to believe that the modem was recognised and installed, I shouldn't be so gullable.
  5. Aeronautical thread starter macrumors member

    May 8, 2005
    I will check again if the modem extension is actually installed. I assumed that any extensions necessary would have been installed along with the OS.

    It wasn't a joke about crucial updates. But it does seem kind of funny reading it back. I think I just wanted that feeling of running software update and seeing what it came back with (although if I remember it never did come back with much on OS 9) It's good to know I'm not missing out on anything. I guess the biggest update I'll never be able to take advantage of on this machine is OS X!

Share This Page