Orphaned blocks after emptying Trash

NanoNyrd

macrumors regular
Original poster
Dec 1, 2011
218
0
Hi,

I am constantly (as in several times per week) getting minor corruption of my main drive (256 GB SSD). It always begins with emptying the Trash, every so often that will result in an error stating that one or more files are in use. Usually (but not always) I can get rid of them by rebooting (restarting Finder also worked today), but afterwards Disk Utility complains about orphaned blocks.

I then boot in recovery mode, repair the disk, and the problem is solved. Until it reappear a few days later. :confused:

What could be causing this? And what could I do to fix it?
 
Last edited:

benwiggy

macrumors 68020
Jun 15, 2012
2,186
15
Is this an SSD suppled by Apple, or one that you fitted yourself? If so, what model of SSD, and what Mac?

At what point does Disk Utility complain about "orphaned blocks"? Is this in a Verify Disk procedure after the reboot?
 

NanoNyrd

macrumors regular
Original poster
Dec 1, 2011
218
0
It is an original SSD in a MacBook bought on the net from Apple a couple of years back (where you could get MacBooks with SSD on the net, but not in stores). I have never dared to mess with TRIM.

Code:
  Capacity:	251 GB (251,000,193,024 bytes)
  Model:	APPLE SSD TS256B                        
  Revision:	AGAA0206