OS 10.4.11 - "Apply to enclosed items" greyed out

Discussion in 'macOS' started by CalfCanuck, Jan 23, 2008.

  1. CalfCanuck macrumors 6502a

    Joined:
    Nov 17, 2003
    #1
    I stumped by this issue that affects all my folders and doesn't let me set permissions correctly.

    I'm logged into my computer as a administrator, and have set myself as the owner of a folder. When I get info on the folder and show the details of "Ownership and Permissions", the "Apply to enclosed items..." button is always greyed out. Does not matter if the folder is locked or unlocked, or if I change a permissions, close the info dialog, and then reopen it.

    Here's a screenshot posted by a person with the same problem as me who could not solve the problem either.

    http://www.mac-forums.com/forums/showpost.php?p=465520&postcount=7

    Any ideas?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  3. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #3
    Can you change permissions through the terminal? Even if the terminal does not work either, it may give you some kind of error message to help with the debugging.
     
  4. CalfCanuck thread starter macrumors 6502a

    Joined:
    Nov 17, 2003
    #4
    No, not using FileVault.

    Well, I'm not a terminal wizard, so my knowledge here gets a bit sketchy. But I've tried the following:
    "sudo chmod -R 777 /Applications/folder name". It asks for my password, then after I hit the return then there is no error message or acknowledgment of any action performed. And using Terminal doesn't change the permissions to give Standard users Read/Write access to the folder (which is my goal).

    I've tried moving the folder to the desktop and changing permissions there, but the "Apply to enclosed items" option is still greyed out (as it is with all other folders). I also tried creating a new admin account, but that doesn't solve the issue.

    Quite puzzling ...
     
  5. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #5
    /Applications folder might have an additional layer of security. Who is the owner of that folder? Is it a locked folder? BTW, it is not a good idea to give write access to /Applications folder to standard users.
     

Share This Page