OS 10.5.8 and xquartz 2.4.0 Xnest problems

Discussion in 'Mac Apps and Mac App Store' started by jc1350, Sep 1, 2009.

  1. jc1350 macrumors 6502a

    Feb 4, 2008
    I'm having no luck with using Xnest lately. When I start it, all I get is a black window and in the terminal I get:

    (EE) AIGLX error: dlopen of /usr/X11/lib/dri/swrast_dri.so failed (dlopen(/usr/X11/lib/dri/swrast_dri.so, 5): image not found)
    (EE) GLX: could not load software renderer
    (EE) XKB: Couldn't open rules file /usr/X11/share/X11/xkb/rules/base
    (EE) XKB: No components provided for device Virtual core keyboard
    Couldn't get keyboard.

    I have re-installed and upgraded xquartz (current version is 2.4.0), but no change. I tried the support options from the sourceforge project page, but no luck there. The IRC channel has nothing but the virtual sound of crickets chirping and an existing thread in the mail list offers no relief. I'm about to open a bug report (the only option left), but wanted to check here first.

    Yes, the remote system is configured for xdmcp and nothing on the remote system has changed (not a firewall rule on either end as I've even tried with the firewall off on both ends). I don't have this problem from a linux system I have in a VM, but I don't have a desire to fire up a VM just for this one thing.

    Anyone have any suggestions?

Share This Page