OS 10.5 - Question about reinstall after "invalid node structure" problem

Discussion in 'macOS' started by RJ Perry, Sep 11, 2009.

  1. RJ Perry macrumors newbie

    Joined:
    Sep 11, 2009
    #1
    A week ago, my MacBook began taking far too much time to complete simple functions. Simply opening an application or scrolling through a webpage would set the pinwheel spinning for a good thirty seconds (but often much more). I found that if I tried to watch a video in iTunes it would freeze for several moments before continuing from a point farther along, sometimes without sound, sometimes with sound only and a frozen picture.

    Around this same time I noticed that Time Machine was no longer backing up properly. I have a Time Capsule, and have been backing up my computer on it since February of this year. Now, for some unknown reason, the backups fail every time, despite endless “preparation”. The stated failure being something along the lines of “the backup drive disk image could not be mounted.” I cannot enter Time Machine, nor connect to my Time Capsule.

    I have been trolling numerous forums for several days trying to find answers to my various questions. I tried downloading software and firmware updates, as well as programs like Onyx, only to be informed every time that “mounting failed.” I was led in the direction of repairing my disk permissions, as well as the disk itself, through Disk Utility. This is how I discovered what I believe is the underlying problem. When I attempted to repair the disk after booting up from the installation disk, Disk Utility gave me the dreaded “invalid node structure” error.

    From what I understand, I can either shell out $100 for DiskWarrior (and wait however long it takes to get the CD in the mail because I can’t download anything) and see if maybe that can fix the problem, or I can wipe my drive and reinstall.

    What I really want to know is, if I’ve been backing up my computer on my Time Capsule all this time, do I really have to go out and clone my harddrive (whatever that means, exactly…) before I erase and install? Or can I somehow get all my files and folders off of my Time Capsule once I’ve reinstalled OS X?

    Whatever info you can give me would be greatly appreciated.

    Please assume that I haven’t the faintest idea what it means to “repartition a drive” or “mount a disk image” or why those things allow my computer to work the way it’s supposed to. I simply want to fix the problem without losing all my data or royally screwing up my system. (Fast and free would be good, too.)

    PS. I used the installation disk’s hardware test and everything seems to be working fine.
     
  2. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #2
    That sounds more like a failing hard drive. Given the extended, random pausing, corrupting of files and repeated filesystem damage spending money on Disk Warrior will probably end up being a waste. One thing to note is that Apple's hardware test is pretty much useless unless there is a colossal error in a very specific area. I would suggest downloading SmartUtility and running a "long test" on the drive (assuming it doesn't immediately pop up as failing).
     

Share This Page