OS 10X panic: We are hanging here...

Discussion in 'macOS' started by nants21, Aug 14, 2008.

  1. nants21 macrumors newbie

    Aug 14, 2008
    Ok first this is the first time i am working on \ trying to fix a mac. This is my girlfriends ibook g4 that is roughtly 4-5 years old. She receives this message when she tries to boot up her laptop. She believes the OS is version 10.1 or 10.2

    I have tried searching for a few troubleshooting tips but have had no luck. For example, I tried booting into Safe mode with no luck. maybe i wasn't holding the right keys? not sure

    She does not have the original cds that came with the laptop. so that check disk utility isn't an option.

    I also saw this article. http://support.apple.com/kb/TS1417
    but could not get to the command prompt to run fsck. once again not sure if i am holding the right keys or it's a timing issue? i thought this would have been my best option.

    I am not familar with the Mac commands or basic settings so please be patient with me.

    I would like to try to stay away from data recovery if possible.

    can anyone help me please? i would really appreicate your help.
    Thanks in advance
  2. wightstraker macrumors regular

    Dec 18, 2007
    Always save these!

    Start up in single user mode by holding down Command+s (Apple key+s) as soon as you start up your computer. You should get a command prompt at start up (white text, black screen).

    Type in the following:

    /sbin/fsck -fy

    Hit return, wait a while. If everything is ok, you'll eventually see this:

    ** The volume (name_of_volume) appears to be OK

    Otherwise, you'll see this:


    If you see that, cross your fingers and try /sbin/fsck -fy again.

    If everything is resolved, restart with the following command:

    shutdown -r now

    Good luck.
  3. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    Alternate (simpler) fsck instructions:

    Restart with the cmd-s keys held down, until you see a black screen with white characters. After the text stops scrolling, at the command prompt, type:

    fsck -f [including the space, return]

    If any repairs are reported, run fsck again until none are reported. Then, at the command prompt, type:

    reboot [return]
  4. nants21 thread starter macrumors newbie

    Aug 14, 2008
    It doesn't seem to start in single user mode. I' m holding command + s at the same time when starting up. it just keeps going to the gray screen then the error occurs again.

    I've tried holding the keys before powering it on... I've also tried holding them right after powering it on :(
  5. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    If you can't start in single user mode, then I'm guessing a hardware problem of some kind.
  6. nants21 thread starter macrumors newbie

    Aug 14, 2008
    oh i wanted to add that the error starts with
    "panic(cpu 0 caller 0x002E54BC) : unable to find driver for this platform: "PowerBook6,5"

    then there are some kernel messages

    lastly "panic: We are hanging here...."

    wasn't sure if the first message would help at all.
  7. pibiling macrumors newbie

    Mar 21, 2009
    panic kernel

    I found this when I was trying to format a new external drive using my dear old G4. I used the CD from the MacBook Pro OS 10.4.10. and got the kernel panic. When the computer booted, I got the terminal, but it would not prompt. I entered the fsck -f anyway and hit return. When I rebooted I held down the click bar on the track pad to get the CD out of the bay. Once the CD was out, the G4 started like nothing had happened.

Share This Page