OS 3.0 Extracting Zip file problems

Discussion in 'Jailbreaks and iOS Hacks' started by roca250, Aug 1, 2009.

  1. roca250 macrumors newbie

    Joined:
    Aug 8, 2006
    #1
    I'm downloading the ipsw file from different sources but all of them when when finished downloading will extract a folder full of dmg images, several plist files and another folder, not the ipsw file I need. If tried this on several macs, different versions of OS 3.0 for various iphones and still the same result. This has never happened before. One fo those dmg images does have the 270 mb size, but when I try to mount it it asks for a pass. Any ideas?
     
  2. mikehockenballs macrumors member

    mikehockenballs

    Joined:
    Nov 6, 2007
    Location:
    Greater Manchester, England
    #2
    Hi roca250,

    Im not sure if this is the same issue that I have previously had or even if it will work for you but here goes ...

    I use a windows pc and I downloaded an ipsw but when it was complete it would not unzip/unrar etc... and I was stumped as to why not, so I think I made a post on these forums and I think the answer that I got was to rename the actual file name type at the end of the text from 'whatever it says now ie .rar or .zip etc... to .ipsw' when I did that the file type changed and it worked as normal for me.

    Good luck!
     
  3. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
    You can solve this problem if you download with Firefox instead of Safari.

    This is because Safari does something peculiar when it downloads zip files. If you download with Firefox, you will have the file named something.zip, and you change the .zip to .ipsw. Don't unzip it, just rename it.
     
  4. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
    #4
    This is what worked for me. I was able to simply rename the 3.0.1 after downloading from Safari, but not the 3.0. That I had to download from Firefox.
     
  5. roca250 thread starter macrumors newbie

    Joined:
    Aug 8, 2006
    #5
    Thanks, Moi un Mouton, worked like a charm !!!!
     

Share This Page