OS 4 and visual voicemail

Discussion in 'iPhone' started by jontucker, Apr 9, 2010.

  1. jontucker macrumors 6502

    Joined:
    Nov 5, 2007
    #1
    Anyone else having a problem?

    I can see all my existing voicemails (pre upgrade) but any new ones that come in are there briefly but then disappear. They are still on the server however because I can dial in and listen to them.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Thats what happens with betas.
    Alot of stuff will still be buggy....
     
  3. Jimmie Geddes macrumors regular

    Joined:
    Jun 25, 2007
    #3
    Just tried leaving a voicemail and had no issues with it showing up or playing in visual voicemail.
     
  4. laughingperson5 macrumors 6502

    Joined:
    Jan 2, 2009
    #4
    Eh, just wanting to ask. Any changes in the phone app?
     
  5. palmerized macrumors regular

    Joined:
    Nov 15, 2007
    Location:
    Toronto, ON, Canada
    #5
    I too am having this problem. I'm on Rogers in Canada. Not sure if that's the issue. Also - no home screen wallpaper.



     
  6. Carniphage macrumors 68000

    Carniphage

    Joined:
    Oct 29, 2006
    Location:
    Sheffield, England
    #6
    Me three.

    I see a voicemail notification - but launching voicemail reveals no new messages.

    C.
     
  7. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #7
    Works great for me. And I love how the voicemail notification gives you the option to listen to the message.
     
  8. jontucker thread starter macrumors 6502

    Joined:
    Nov 5, 2007
  9. RichL macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Chicago
  10. Carniphage macrumors 68000

    Carniphage

    Joined:
    Oct 29, 2006
    Location:
    Sheffield, England
    #10
    Perhaps it is a carrier-side issue?

    I am seeing the problem on O2 in the UK.

    C.
     
  11. Graeme43 macrumors 6502a

    Graeme43

    Joined:
    Sep 11, 2006
    Location:
    Great Britain (Glasgow)
    #11
    Same here but after a reboot it fixed my voicemail issue. I had a voicemail from the day before which kept popping up saying I received a voicemail but then when went to play it there was none! Glad its stopped doing that now! :D

    any luck on the home background?
     
  12. Carniphage macrumors 68000

    Carniphage

    Joined:
    Oct 29, 2006
    Location:
    Sheffield, England
    #12
    Rebooted. Once again got the voicemail notification.
    But no red button - and nothing at all in VVM!

    C.
     
  13. phatspider macrumors 6502

    Joined:
    May 20, 2005
    #13
    Mine doesn't do this?
     
  14. sneeks macrumors 6502a

    Joined:
    Oct 21, 2007
    Location:
    Glasgow, UK
    #14
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.4 Mobile/7D11 Safari/531.21.10)

    Same problem on o2 for me.
     
  15. Wheezy13 macrumors newbie

    Joined:
    Apr 8, 2010
    #15
    Same problem here on Rogers, notifies me that I have a voicemail but when I hit "Listen" it takes me to an empty voicemail list.
     
  16. Mikey B macrumors 65816

    Mikey B

    Joined:
    Jan 4, 2008
    Location:
    the island
    #16
    Really? Does for me, just like so:
     

    Attached Files:

  17. bks691 macrumors regular

    Joined:
    Apr 18, 2009
    #17
    Maybe it's a network issue? Mine works fine with OS 4.
     
  18. jontucker thread starter macrumors 6502

    Joined:
    Nov 5, 2007
  19. Allisone macrumors newbie

    Joined:
    Apr 14, 2010
    #19
    Having the same problem
    iPhone 3GS 32GB
    Germany
    T-Mobile

    When I call myself and record a new message I get the german version of the new Voicemail Alert and the badge number appears on my phone App Icon. It starts with 4 and then each second reduces by 1, thus you could say I see a countdown: 4, 3, 2, 1, and then nothing. If I click (very fast) on Listen I can see the same process in the Voicemail Table.

    Restart didn't help.
    Hope someone finds a solution
     
  20. Allisone macrumors newbie

    Joined:
    Apr 14, 2010
    #20
    Found this:
    "remove your phone app from the folder and put on your desktop, NOT in a folder, then all your voicemail will appear, once you receive another voicemail."
    Doesn't help me though
     
  21. Carniphage macrumors 68000

    Carniphage

    Joined:
    Oct 29, 2006
    Location:
    Sheffield, England
    #21
    Me either.

    C.
     
  22. gmanrique macrumors 6502

    Joined:
    Oct 22, 2003
    Location:
    Ottawa, Canada
    #22
    same problem

    on an iPhone 3G in Fido network (which is Rogers). If I have voicemail open already, I see the whole list (including all the new messages) but then they disappear one by one until all the new ones are gone.

    Also, regarding the custom background, it is weird since it shows the raindrops a couple of times when unlocking the phone and when dialing a phone number. After that it went back to black and I can't find the raindrops one, not even to set is as the wall paper.
     
  23. Allisone macrumors newbie

    Joined:
    Apr 14, 2010
    #23
    Went crazy and tried lots of things

    What I did

    1. Called my (voice) voicemailbox.
    2. Listened to all messages completely (10 messages).
    3. Listened again (just beginning), and deleted one after the other
    4. Hang up
    5. Took my Phone App in iPhone and moved it from the Dock to a new page in the iPhone (6th or so)
    6. Called my iPhone again and recorded a message.
    7. Visual Voicemail shows the record.

    Also pushed play button. Worked fine. Also pushed Home button, back to phone App, all ok, turned off all Connections (Airmode ??? in german: Flugmodus), still message in VVM

    8. Turned off iPhone, and on again

    After that.
    Voicemail is still shown and playable, but marked as new again


    9. Played message again and again. iPhone turning off and on, always same problem (message marked as new).

    10. Called iPhone again. Recorded second message.

    Second message won't show up. (Voice) Voicemailbox tells me that I have 2 new messages, thus not the code but t-mobile is telling the iPhone that the message hasn't been played yet / iPhone not telling t-mobile that I did.

    11. Deleted first message (the only one being shown)
    12. iPhone restart etc. doesn't bring any voicemail entries.
    13. Made new call.
    14. Now (Voice) Voicemailbox tells me I have 3 new messages, but in VVM the table is empty. (Thus iPhone also didn't tell t-mobile that I have deleted the first message)
    15. Started all over again. Didn't work this time. :(
     
  24. richxps macrumors 65816

    richxps

    Joined:
    Jun 9, 2008
  25. RockinRon macrumors newbie

    Joined:
    May 18, 2009
    #25
    Vodaphone Australia

    Doesn't work here either....
     

Share This Page