OS 4 wifi now not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iphoneuser2040, Jun 22, 2010.

  1. iphoneuser2040 macrumors newbie

    Joined:
    Jun 22, 2010
    #1
    Hi, I am currently at a hotel for work using their internet and it was working fine on 3.1.3. I then updated my firmware to OS 4 and now the wifi no longer works at all. I am on roaming so have not had a chance to try out 3G/edge data.

    Basically, I go to wifi settings and can see the network, I then double tap on it to connect and it ticks the box but does not appear with the wifi icon at the top of the homepage until at least a minute or so later.
    The wifi connection at the hotel is one of those where you have to enter a password into a browser, but when I open up a browser to try to put in the password it does not load. It just stays stuck on a blank webpage.

    Anyone got any ideas if there is a general bug with OS 4 in this respect?
    (I have already tried restoring my Iphone and resetting network settings)

    Cheers
     
  2. iphoneuser2040 thread starter macrumors newbie

    Joined:
    Jun 22, 2010
    #2
    bump,

    is it worth trying another full restore?
     
  3. mmike70 macrumors newbie

    Joined:
    Nov 8, 2008
    #3
    I've just noticed the same thing on my 3GS. I have a network where I need to agree to a terms of service. On 3.1.3, the screen would pop up automatically, I'd hit accept and it worked. Now I never get that screen and the WiFi symbol never appears. Looking in settings under the wifi network config, I'm getting a good IP Address and everything looks normal but the connection never works.

    Any other normal open or encrypted access point works fine.
     
  4. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #4
    I can't even connnect to an open wifi access point now ...

    Seriously annoyed as i can't book a genius appointment at the only time i can get away from work due to the iPhone4 launch

    So what now? I've got no wifi functionality on my phone .... Thanks Apple
     
  5. leaded71 macrumors newbie

    Joined:
    Jun 23, 2010
    #5
    i have a similar problem.

    where i work, every time i use the wifi, i have to accepts some terms and conditions.

    occasionally i get the screen that says

    "safari cannot verify the identity...."

    then you have 3 options: cancel, details and continue.

    when i click continue, i get kicked out of safari all together and back to my iphone icon page.

    i tried to enable the debug log - which has revealed nothing at all, since it doesn't ever connect and i also turned off fraud alert under my safari settings.

    like mmike70 it worked fine with 3.1.3 and currently works on my home wifi (encrypted).

    the settings tab shows that i am connected and i have a full wifi bars at the top of the screen
     
  6. Jasonbot macrumors 68020

    Jasonbot

    Joined:
    Aug 15, 2006
    Location:
    The Rainbow Nation RSA
    #6
    I am able to connect to internet through my wifi router in the house but when i try connect to a network i create with my mac the internet doesnt work through that network.
     
  7. clokeo macrumors newbie

    Joined:
    Jun 23, 2010
    #7
    I am having the exact same problems. I upgraded to OS4 this morning, and it's a nightmare. Not only is my phone slow - I can't connect to WIFI. I can connect via my home router - but I have just got home from visiting a cafe which is a WIFI hotspot - and it won't let me connect.

    I had no problem last week using the old OS. It's showing in my settings that WIFI is enabled - that I am connected to WIFI - but when I load up the internet, it is connecting me via my phone connection and not WIFI.
     
  8. dandylion macrumors newbie

    Joined:
    Sep 14, 2009
    #8
  9. 007bond macrumors 6502a

    007bond

    Joined:
    Dec 12, 2008
    Location:
    DFW, Texas
    #9
    Settings --> General --> Reset --> Reset Network Settings

    Rejoin Wifi Networks and it should work. Thats how I fixed it
     
  10. AliPuss macrumors newbie

    Joined:
    Jul 12, 2010
    Location:
    Melbourne, VIC, Aust
    #10
    OS4 iPhone not connecting at home

    Seems like a regular stuff-up here.
    After upgrading to OS4, I've got an iphone that runs like a dog, AND I can't connect to my home wifi network - Not happy APPLE!!
     
  11. nixjasr macrumors newbie

    Joined:
    Jul 21, 2010
    Location:
    spokane WA
    #11
    No wifi after OS 4 upgrade

    Has this been resolved for anyone else?
    I upgraded to OS4, and now I can't connect to any wifi network. My wife identical 3G still connects as normal. The phone recognizes the wifi signal, but when I enter the psswd and try to connect, all I get is a window that reads "unable to join network" and a "dismiss" button.

    When I click on my network name from settings, I get no information in the IP address, subnet mask, etc.
    Shouldn't the ohone by autofilling this info?

    Here's what I've tried.

    restarting the router (a Time Machine)
    Rebooting the phone
    resetting the network settings
    restoring the phone through "settings"
    restoring the phone through iTunes
    removing the password from the network
    joining a network with no passwd

    I have an iMac and a MacBook Pro in the same house connected wirelessly and there are no issues.
    I'm out of ideas here. Anything I haven't tried?
     
  12. Jim Millar macrumors newbie

    Joined:
    Jul 24, 2010
    #12
    Wifi not working after os4 upgade

    My wifi is not working at all after upgrading to os 4. I could see the networks to join but after every attempt it would come up with "unable to join network". This would happen with all networks. I have tried everything to fix the problem rebooting/restoring etc to no avail. Finally rang the apple help desk and they are going to replace the phone.




     

Share This Page