OS 9, 10.1, 10.4 partitions on 1 new drive?

Discussion in 'PowerPC Macs' started by OSMac, Jan 18, 2013.

  1. OSMac macrumors 65816

    Joined:
    Jun 14, 2010
    #1
    Trying to partition and install os 9 , 10.1, 10.4 on a single 1TB drive in a Quicksilver 2002 G4.

    If I boot from the OS 9 cd and try and set the partitions it does not seem to see the full 1TB size correctly.

    If I boot from Tiger 10.4 dvd it sees the drive and allows the it to be partitioned but when I reboot with os 9 cd it does not see the partitions set up in the Tiger installer, again thinks the drive is smaller.

    Anyway to do this?
     
  2. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #2
    Why?
     
  3. OSMac thread starter macrumors 65816

    Joined:
    Jun 14, 2010
    #3
    One of the original drives crashed and the other is noisy ...
     
  4. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #4
    I'm just wondering why you need 10.1.
     
  5. OSMac thread starter macrumors 65816

    Joined:
    Jun 14, 2010
    #5
    Just wanted to setup the machine as it came with 9.2.2 and 10.1 then add 10.4 and maybe 10.5 as well on the same disc. Just a little project :)

    Tried again, Tiger sees the drive correctly as 931GB and partitions it fine.

    OS 9 and 10.1 only see it as a 128GB drive, doesn't matter if I preformat it in Tiger or not.

    Strange as the QS 2002 is supposed to not have a 128GB limit
    and it doesn't when booted from Tiger?

    Using a IDE to SATA converter maybe that's part of the issue.

    Just thought I'd post to see if anyone else had the issue ever.
     
  6. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #6
    I think it's OS9, which also cannot address more than 1.5gbs of ram.
     
  7. Idefix macrumors 6502

    Joined:
    Jul 10, 2012
    #7
    use Sheepshaver to run 9.04 in emulation, forget about 10.1
     
  8. blesscheese macrumors 6502a

    blesscheese

    Joined:
    Apr 3, 2010
    Location:
    Central CA
    #8
    Hey,

    I ran into this recently and think this applies to your situation: Apple KBase article

    Basically, in addition to the (known) 128gb limit, there is also an issue of the older OS's not being able to see/use drives larger than 200GB...sheesh...

    I'm guessing that is what you are running into.
     
  9. OSMac, Jan 19, 2013
    Last edited: Jan 20, 2013

    OSMac thread starter macrumors 65816

    Joined:
    Jun 14, 2010
    #9
    Thanks that seems to be it.

    OS 9 can work with up to 200GB but OS 10 to 10.1.5 can only work with a max of 137GB.

    10.2 on works with large drives no problem.

    So its probably best to use a smaller drive(s) for 9.2.2 and 10.1.

    Found this too explaining the issue


    Symptom: Disk space reported under Mac OS X is less than reported under Mac OS 9.x.

    Issue: Mac OS X, Version 10.0 through 10.1.5 does not support the 48-bit addressing utilized by hard drives with capacities greater than 137GB, but Mac OS 9.x does. As a result, Mac OS 9.x accurately reports disk space on these drives, but Mac OS X, Version 10.0 through 10.1.5 does not; these OS versions report a maximum of 128GB of disk space.

    Note: Because of this lack of support, data corruption may occur on these high capacity drives.

    Affects: Any of the computers listed above running Mac OS X, Version 10.0 through 10.1.5 with Tempo RAID133 installed and a hard drive with a capacity greater than 137GB.

    Solution: The drivers for large drive support are included in Mac OS X, Version 10.2 through 10.2.x; upgrading from an earlier version of OS X to Mac OS X, Version 10.2.x will alleviate this .

    Issue: There is a limitation in Mac OS 9.x that will not recognize a volume larger than 190GB.
     

Share This Page