OS versions confusion

Discussion in 'iOS Programming' started by mattpryor, Feb 11, 2010.

  1. mattpryor macrumors newbie

    Joined:
    Feb 11, 2010
    #1
    Hello all,

    I'm fairly new to Mac development and iPhone programming. Currently working my way through "Beginning iPhone Development" by Apress.

    Here's the problem, which I would be very grateful to have some assistance with:

    I've just upgraded XCode to 3.2.1. My iPhone is on version 3.1.2 (7D11)

    When I try to build and run a new project I get the following error pop up:

    I've gone into the project settings and set the Base SDK for all configurations to be "iPhone Device 3.1.2" under General.

    Under the "Build" tab the iPhone OS Deployment Target is set to iPhone OS 3.1.2.

    Please could someone nudge me in the right direction of what else needs to be configured? I'm sure it's something simple but I'm at a loss.

    Thanks very much in advance.
     
  2. mattpryor thread starter macrumors newbie

    Joined:
    Feb 11, 2010
    #2
    If anyone's interested in how I fixed this, I changed the "Bundle version" in info.plist from 1.0 to 1.7 and it seemed to work fine.

    I've no idea why this is the case - seems to have nothing to do with the OS version - but I took the value from a plist file for a project that I knew worked and it did the trick.
     
  3. barneym macrumors newbie

    Joined:
    Feb 16, 2010
    #3
    I believe the only requirement is that you edit and resave the info.plist file. I editted to 1.7, saved, and then back to 1.0 and it worked fine.

    It may be that XCode is binding in additional details from the build settings at the time of packaging and since the info.plist hadn't changed those additional bindings did not get attached. If this is the case I would consider it a bug.

    Barney
     
  4. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    The Deployment target field is what controls this. Xcode sets a MinimumOSVersion key in the Info.plist file based on the project setting.
     
  5. CarolineJack macrumors newbie

    Joined:
    Feb 18, 2010
    #5

Share This Page