OS X 10.10.4 and Wi-Fi Performance

Discussion in 'OS X Yosemite (10.10)' started by hsouris, Jul 1, 2015.

  1. hsouris macrumors member

    Joined:
    Mar 21, 2011
    #1
    So, I've been using WiFriedX for the past several weeks since otherwise my Wi-Fi speed drops below 1mbps.

    You can imagine my joy when OS X 10.10.4 dropped support for discoveryd. Unfortunately, after I installed the update and deactivated WiFriedX nothing - absolutely nothing - changed. I restarted my router/Mac with no result.

    Anyone else still having problems? I hate even the thought of having to clean install 10.10.4 from the beginning :(
     
  2. navaira, Jul 1, 2015
    Last edited: Jul 1, 2015

    navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #2
    My problem not only persists but seems worse: wifi stops working, despite icon telling me it is on, switching off-on helps but with Apple Music it's even more irritating than ever. I had great hopes for discoveryd being replaced. Too bad.

    Edit: the error Chrome provides me with is "ERR_NETWORK_CHANGED".
     
  3. border terrier macrumors regular

    Joined:
    Feb 6, 2013
    Location:
    England
    #3
    It's very early days and there have been a (very) few odd periods when I have been untroubled by wifi connection issues however so far my 2009 Mac Pro has connected to wifi and remained stable. The 2014 MBP seems fine though some website are still slow to load on occasion. Maybe in a week or so I can be more positive.
     
  4. williamapple macrumors newbie

    williamapple

    Joined:
    Jun 30, 2015
    #4
    For me the same, my safari/wifi issues remain. I can't believe, I have had these issues for 3 years now, still no fix . I am seriously considering ditching osx, I'm getting hopeless. :-s
     
  5. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #5
    I just did this (from discussions.apple)

    1. Creating a New Wi-Fi Service (this solution worked for me!)
      • Copy and paste these instructions, because you'll be disconnected from the Internet and you'll need to reboot.
      • Go into your Network Preferences > Select Wi-Fi Service (in the list in the left column) > Click on the options (cog icon) > Select "Make Service Inactive" > Select Apply.
      • Select the same Wi-Fi Service > Delete It ( – ). Reboot.
      • Return to Network Preferences > Create a New Service ( + ).
      • Inside the prompt select Wi-Fi under Interface, name the Service Name something other than Wi-Fi. (I named mine Wi-Fi2. Apparently if you retain the previous Wi-Fi name the WiFi dropping will return on reboot.) > Click Create.
      • Click Apply.

    It's been working for, well, 15 minutes, but that's the best result since 10.10.4 update.
     
  6. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #6
    This worries me. I've been waiting for a fix since Yosemite was released.

    I did install the update last night and gave it a quick go. Waking from sleep was the same, it either took a long time or I had to turn wifi on/off. Everything else appeared to be okay, I'll see how it goes.

    I honestly can't fathom how Apple can't get this right. There is only a handful of machines they have to support!
     
  7. hsouris thread starter macrumors member

    Joined:
    Mar 21, 2011
    #7
    I tried it, but didn't work.
     
  8. seong macrumors 65816

    seong

    Joined:
    Feb 11, 2010
    #8
    I have the new rMB and it seems to be fine thus far. No issues to be found, unlike the 10.10.3.
     
  9. tampageek macrumors 6502

    tampageek

    Joined:
    Jul 1, 2015
    Location:
    Florida, USA
    #9
    This worked for me. It's like getting a new computer it's so much faster now. Thanks
     
  10. Fester1952 macrumors member

    Fester1952

    Joined:
    Jul 22, 2012
    Location:
    Adelaide, Australia
    #10
    It's been great for me, waking from sleep now is instantaneous. But recently I added an Airport Extreme in my network mix so whether that has some influence. I may try reverting my iMac 5GHz wireless back over to the Asus router and see if that is the same.
     
  11. rasputin666 macrumors member

    rasputin666

    Joined:
    Mar 1, 2009
    #11
    I am going to give this a shot. nothing else has worked for me. very disappointed.
     
  12. rasputin666 macrumors member

    rasputin666

    Joined:
    Mar 1, 2009
    #12
    OK-let the clock begin from 8:30pm EST, see how long i have wireless
     
  13. evolkatie macrumors member

    Joined:
    Sep 12, 2014
    #13
    The update seems to have fixed my issues. I actually did a fresh install since I went from el capitan back to 10.10.4 for this. No drops all day.
     
  14. mosher macrumors member

    Joined:
    Jul 16, 2013
    Location:
    Germany/Ukraine
    #14
    i had no drops in 10.10.3 after updating to 10.10.4 every time i open new website or create new tab in Safari internet drops. Also Mac Appstore takes forever to load.

    P.S. in Chrome there are no drops
     
  15. hsouris thread starter macrumors member

    Joined:
    Mar 21, 2011
    #15
    I have several problems presumably with Wi-Fi. For some reason now my Wi-Fi connection works without WiFriedX. No idea why. It just worked (and still does).

    But occasionally all hell breaks loose. Apple Music gets stuck and then Safari doesn't load any pages while Chrome works fine. The same happens with my iPhone. I have to restart my Mac but sometimes the problem is still there. I can't pinpoint the cause, is it Apple Music hogging the internet?
     
  16. Sym0 macrumors 6502

    Sym0

    Joined:
    Jun 6, 2013
    #16
    No issues here, but then I never had any on any OS X version, or Windows or an other device on my wi-fi.
     
  17. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #17
    After testing for a day. Waking up from sleep I still either have to leave it for a minute or 2 to connect or I have to turn off wifi/turn it back on.

    I did have one instance where safari wouldn't load or do anything until I turned wifi on/off again.

    For me it's much much better but it's still not perfect. I am still perplexed how they can have this problem for so long without a fix.

    On mavericks the second my screen turned on wifi was operational and there were no drop outs. It's frustrating that I no longer have this.
     
  18. Jigga macrumors 6502

    Joined:
    Jun 11, 2009
    #18
    Some sites no longer load for me. Even after the fix above.
     
  19. williamapple macrumors newbie

    williamapple

    Joined:
    Jun 30, 2015
    #19
    thanks a lot for the suggestion...
    I have to say, this seems to have solved my issue. I tried something similar already, but with only temporary results. This specific method seems to work like a charm. I really hope it stays this way. (fingers crossed)
     
  20. neteng101 macrumors 65816

    Joined:
    Jan 7, 2009
    #20
    Crazy stuff that we have to do this - but since 10.10.4 my wi-fi has been a nightmare, so far this fixed it. We'll see if it lasts.
     
  21. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #21
    Apple has been like this for a while – "it just works, unless it doesn't, and then you have to do something really odd to make it work again". My problem is fixed too thanks to this. Why? No idea.
     
  22. Romanesq macrumors 6502a

    Romanesq

    Joined:
    Jun 16, 2003
    Location:
    Hoboken
    #22
    I'm seeing the best, smoothest wifi performance now thankfully.
    Seems to be running both smoother and cooler too.

    10.10.4, 15" Penryn, 6GB RAM, 256 SSD.
     
  23. border terrier macrumors regular

    Joined:
    Feb 6, 2013
    Location:
    England
    #23
    I'm still OK on MBP and the formerly very problematic Mac Pro. No issues so far other than the odd slow page load.
     
  24. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #24
    It's been pretty perfect for me so far other than slow connection to wifi from sleep.
     
  25. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #25
    Because nobody can. Steve Jobs was wrong about blu-ray being a bag of hurt, wifi is the actual bag of hurt here, especially if you have a multitude of devices that connect to your wifi network. You can change settings all you want, the only thing that changes is the person who's complaining that it doesn't work (or in other words: fix it for someone means breaking it for someone else). Android users, Windows users, they are all coping with wifi issues. At this point it is simply the technology itself that is failing. I'm hoping that the successor of 802.11ac will be aimed at fixing the mess that is wifi instead of increasing speed (what use is speed if you can't even use the connection properly?!).
     

Share This Page