OS X 10.5.1 Locked folder cannot be deleted [External HDD][Read Only?] *Solved*

Discussion in 'macOS' started by GloStix, Jan 8, 2008.

  1. GloStix macrumors member

    Joined:
    Jan 8, 2008
    #1
    I came from Windows XP about a month ago. I finally switched. And I love my MacBook Pro to bits. Will never go back to XP (I was a hardcore XP user)

    I found a folder on my External HDD and for some reason it has a lock on the corner, everytime I try to trash it. It tells me to type a password. I do so. And then nothing happens... Seriously... Nothing..
    I'm sure it was the right password because any other password is says "Wrong Password"
    It even makes that noise when you trash something except nothing actually goes in the trash.

    I go to "Get Info" and it says under "Sharing & Permissions" "Read-Only"
    I don't know why it says this. I didn't exactly "Lock" anything when I was using Windows XP. I may have Hidden the folder but non of the other folder became like that..

    Any Ideas?
    :confused:
     
  2. McGiord, Jan 8, 2008
    Last edited: Jan 30, 2011

    McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #2
    It seems that your user isn't allowed to modify that particular folder. You must login with the user account that owns that folder or an Administrator account.

    As far as I'm aware:

    If it is a Windows formatted HDD you can't write on it via MacOSX, unless you have some Windows utilities on your Mac (I think with Parallels Desktop 3.0 Tools you could), or by running a Windows Session via BootCamp.

    If it's a MacOSX formatted HDD you need to login with an Administrator User account, then Get Info on the folder, then click on the lock to unlock it, it will require the password and then you'll be able to change the access privileges (permissions) to do whatever you want to do.

    General tip: if the folder is beign used by other user or app it may not be erased also.
    ________
    medical marijuana strains
     
  3. GloStix thread starter macrumors member

    Joined:
    Jan 8, 2008
    #3
    I'll try it in Windows via Boot Camp though I'm not sure why it would be locked..
    I didn't even lock it with Windows or anything.
     
  4. GloStix thread starter macrumors member

    Joined:
    Jan 8, 2008
    #4
    I figure it out myself, I just moved all the contents(In Windows) to a new folder outside of the original one and it wasn't locked. I unhide the folders that were hidden but it was still locked, I even delete the desktop.ini and thumbs.db files but they were still locked. But at least they are unlocked.
    My ExHDD is Windows formatted so I can't exactly lock a folder on there.
    Thanx anyway
     
  5. Octobot macrumors regular

    Octobot

    Joined:
    Oct 30, 2006
    Location:
    MPx12
    #5
    Ya I'm having a similar problem.. really frustrating.

    Though now that I found this thread.. it made me realize that the files probably originated from my windows partition, which I then moved over to
    my mac osx partition and into the trash there.

    Now when I try to take the items out of my trash, they are being copied instead of moved. :mad:

    So I'm trying to figure out how I'm going to go about this..
    What I want to do is bring the files back over to Windows and get rid of them there.. But if its still leaving a copy in my macosx trash, how am I going to
    get rid of that??

    Anyways I'm going to try some things.. will report back if I get this solved.
     
  6. GloStix thread starter macrumors member

    Joined:
    Jan 8, 2008
    #6
    Well If you try to move it onto windows and its copying then maybe you can keep that copy and move that to windows partition and then just empty the trash. If not then just delete it using Windows :confused:
     
  7. Octobot macrumors regular

    Octobot

    Joined:
    Oct 30, 2006
    Location:
    MPx12
    #7
    When I try to pull the "locked files" out of my trash (osx) they don't leave the trash they just copy, so Even if I drag them to my Windows partition, there is still the copy in osx's trash. Really frustrating.. I've tried all types of "force deletes".. nothing is working.. I gave up for now.

    ------

    Nevermind I actually thought I tried this already.. It Works! Dragging from OSX's trash -> directly to windows desktop on partition. Thx GloStix.
     
  8. Fastshutter Guest

    Joined:
    Aug 21, 2007
    #8


    I've had this same issue for about two months and I've done everything I could think of to get the locked file out of trash.

    Turns out the file originated from the windows drive and I simply had to drag it back to the share to get it out of the trash bin.

    Thanks a ton for sharing, I can't tell you how much time I've invested in getting this file deleted.
     
  9. anmoldagreat macrumors member

    Joined:
    Feb 29, 2008
    Location:
    seattle
    #9
    hate to bring back an older thread but im having the exact same problem and i dont understand the solution that is working for everybody else.

    when i move stuff from my trash to windows it copys and then i still cant do anything to delete them...
     

Share This Page