os x 10.5.6 akai mpd24 mpd32 issue

Discussion in 'Digital Audio' started by bosonhavoc, Jan 10, 2009.

  1. bosonhavoc macrumors newbie

    Joined:
    Jan 10, 2009
    #1
    we just got a new mac book pro and i'm getting it set up as our stage performance computer.

    mbp 10.5.6 fully updated
    mpd 24 current firmware ver 1.10
    mpd 32 current firmware
    ableton live 7.0.14 fully updated

    i'm having an issue with both the mpd 24 and mpd 32
    they function fine except for the extra midi ports are not functioning.
    for the port that is internal to the mpd's (1b-16b) ableton sees activity but isn't getting any data
    for the physical port ableton sees no activity at all

    in the audio midi setup utility i can test my midi set up and all ports show activity. --see screen shots below

    i've tested my MPD24 on
    win xp sp3.. works fine
    mac g4 10.2.8 fine
    a friends macbook 10.4.? (current) works fine

    also i have reset the pram, repaired disk permisions,
    and ran the through the leopard cache cleaner

    only on the mbp 10.5.6 do i have an issue
    also i've tested an m-audio axiom which has 2 midi ports
    that worked fine on my macbook pro
    i've used the same usb cable for all tests
    but i've also tried other cables plus going through a powered usb hub


    in audio midi set up it looks like this

    [​IMG]


    notice it only shows port 3 and what would be port 1 is selected.
    it should say port 1, port 2, port 3


    and in ableton


    [​IMG]

    in the () its suppose to say (port 1), (port 2) (port 3)



    also if anyone has osx 10.5.6 and mpd24 or mpd32 and all midi portd are working please let me know cause i'm triing to figure out if this is a n isolated issue or not.




    by the hi all :)
     
  2. chrisinlondon macrumors newbie

    Joined:
    Jan 6, 2009
    #2
    i have the same - it's an os 10.5 problem. ableton support told me this, i tried my old 10.4 machine with mpd32 and live 7.0.14, and sure enough it works properly.

    i'd suggest making a bug report to apple here, to let them know about the problem.

    also contact akaipro support and ask them to work on it too.

    i have other issues with the mpd32:

    - The mpd32 doesn't save all the global settings (including pad sensitivity/curve etc) when powered off (the manual states it should). this is incredibly annoying in daily use.
    - The mpd32 faders don't work with soft takeover in live (or any other DAW)

    do you have these problems too?
     
  3. Chairman Plow macrumors regular

    Chairman Plow

    Joined:
    May 15, 2008
    Location:
    CT
    #3
    With the MPD controllers, if you want to use the other MIDI in/out (not the USB port) you need the optional power supply. I came across the issue a while back when I had the MPD24.
     
  4. chrisinlondon macrumors newbie

    Joined:
    Jan 6, 2009
    #4
    that's not strictly true. i have been able to send MTC from my soundbite micro via the 5-pin midi in port on the back of the mpd32, and receive it in Live.

    is seems that there is some configuration requred using the Vysex editing software for the MPD32 (on os x, anyway) - and then it can work.

    the port preferences part of the Vysex software are very hard to understand. i'm not sure what is going on at all. i have no idea how it supposed to work, i just played around with some settings.
     

Share This Page