OS X 10.5.8 server problem!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by likeamojay, Sep 28, 2010.

  1. likeamojay macrumors newbie

    Joined:
    Sep 28, 2010
    #1
    I had my G4 web server running OS X 10.4.11 Tiger Server and hosting a website on it and everything worked fine until I upgraded to 10.5.8 Server. My configuration hasn't changed at all and now every time anyone tries to access my website they get an error 403 saying "access forbidden"!!!

    I've repaired disk permissions and made sure all the website files are able to be viewed but I still haven't had any luck. I found a support article on Apple's website for the exact same issue on personal web sharing on OS X 10.5.8 client version. But the server version config files are different than the client version. I even tried following that support article which involved doing a sudo command and that didn't help either. Anyone have any ideas????

    Thanks
     
  2. etchtech09 macrumors member

    Joined:
    Jun 25, 2010
    #2
    Have you checked the /var/log/apache2/error_log and /var/log/apache2/access_log?

    When you get the access denied, are you doing this from another computer or from the localhost?

    What are you typing to get to the webserver? IP address, host name?
     
  3. likeamojay thread starter macrumors newbie

    Joined:
    Sep 28, 2010
    #3
    I'm accessing the web server using a domain name I set up. Again, my configuration I know is not the problem because it worked fine until I upgraded to Leopard Server. I've tried accessing it from the server itself, computers on my network, and computers other places and all produce the same "error 403 access forbidden" page. I'll have to check the log later.
     
  4. etchtech09 macrumors member

    Joined:
    Jun 25, 2010
    #4
    I understand your sentiment about it not being the configuration, but there have been more times than I care to admit that the problem was something that I thought could never possibly be the problem.

    The Apache configuration could have changed with the upgrade to be setup to only allow connection from a specific IP range or only localhost or something else entirely. The upgrade from 10.4 to 10.5 surely upgraded the version of Apache, and as part of that the security features could possibly have changed.

    If I were you, I would at least comb through the Apache configuration file to be sure. I wish I could be more specific, but I wasn't involved in our servers upgrade from 10.4 to 10.5.
     

Share This Page