OS X 10.8.2 wifi issue

Discussion in 'OS X Mountain Lion (10.8)' started by tommy060289, Sep 22, 2012.

  1. tommy060289 macrumors regular

    Jun 20, 2011
    Hey everyone,

    I upgraded to 10.8.2 when it came out but ever since I've been having wifi issues on my 2011 27" iMac.

    There doesnt seem to be any pattern to it or anything but Ill be on the internet and all of a sudden the connection seems to time out. The iMac still says its connected to the wifi network but no web pages will load and the little green tick on drop box disappears. Sometimes disconnecting the wifi and reconnecting fixes it and sometimes it doesnt.

    I've not noticed any issues with any other devices such as my iphone or my laptop on 10.8.2 but then again I barely use the laptop (a 2009 MBP). I also seem to have issues with time machine since the upgrade as I haven't had a successful back up since and now cant seem to get the time machine to readd the drive. This is a Western digital my world book.

    I was hoping to google 10.8.2 wifi problems and find others were having problems and maybe a solution but I havnt seen any and wifi has always been solid as a rock prior to 10.8.2.


  2. Krazy Bill macrumors 68030

    Krazy Bill

    Dec 21, 2011
    My wife's MBP does the same thing.

    This has been an ongoing problem with the OSX "Lions" for as long as I can remember. Some people have this issues and others don't so it's hard to nail down. Ironically, my machine running Snow Leopard has no issues at all with wi-fi. (or anything else for that matter).
  3. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    1. First try a Reset Your PRAM to see if it helps.

    2. Tell us what wireless signal OS X is having with (a, b, g or n).

    3. Don't panic.
  4. jackbauer538 macrumors newbie

    Sep 22, 2012
    I have exactly the same issue here, iMac 27 Inch end 2009 connected to a Netgear WNDR4000 (on 5Ghz).

    Network signal is still there but no internet connection. All the other devices on the network (also WiFi) can still access the internet.

    Problem can be solved by either rebooting my iMac or the Netgear router.

    Never had this issue before, it happend now 2 times in 1 day after upgrading to version 10.8.2:mad:
  5. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    Will try resetting the PRAM and see what happens.

    Im using n-type wireless with 5-GHz network but ive tried adjusting things and never really had any luck with that:(

    Turning wifi on and off again seems to fix it but irritating and doesnt stop it happening again. Also, the wifi just seems to have problems picking up other wireless networks when jst switched on like I have been using my iphone to tether (over wifi) to get round it but sometimes it takes a while to appear but then connection doesnt drop to the iphone strangely:/ but no other devices like laptops or iphone having problems wifi in the same room or even further away!

    Edit: Just found this on Apple Support: http://support.apple.com/kb/HT1379?viewlocale=en_US&locale=en_US. Suggests resetting PRAM wont do anything for network problems.
  6. mackid1993 macrumors member

    Aug 16, 2009
    I would recommend going into your router's settings and changing your network to 802.11g 2.4ghz. ML has a problem with n Wi-Fi. My connection used to drop constantly-- but after I tried this, it has been stable for nearly a month with heavy usage. This is really an issue that Apple needs to sort out. :rolleyes:

    EDIT: I'm not sure if 2.4 vs 5.8 ghz actually matters with this... those happen to be my network settings. If you have interference issues (ie. a cordless phone) I'd suggest changing to 802.11g. If that doesn't solve it, then change your network to 2.4 ghz. Also, if you option click the Wi-Fi icon in your menubar, you can see if you are connected to an 802.11 b, g, or n network. It will also show you the channel, signal strength, and frequency. Good way to confirm if your protocol change worked. Hope it helps! :)
  7. jackbauer538, Sep 23, 2012
    Last edited: Sep 23, 2012

    jackbauer538 macrumors newbie

    Sep 22, 2012
    My iMac has the Atheros 9280: chipset build in for WiFi, which chipset do you have in your iMac?

    in my opinion it's a bug in 10.8.2, never had issues before with 10.8.1 and older.
  8. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    Im not sure of my chipset as I havnt't checked it but it is most definetly OS X 10.8.2 as it never did this before.

    Very frustating. Tried playing with different wifi settings but no fix:(
  9. SyncFx macrumors member

    Feb 27, 2011
    Vancouver, BC
    I had WiFi issues since I installed 10.8.1, which actually ported over to my Bootcamp as well. Here is a fix:

    Open your Network preferences and select Advanced on WiFi. Go to the Hardware tab and change the MTU value to lower than 1500 *1500 is the highest and default* I set mine to 1400 and WiFi works like a charm, also set it to 1400 in Bootcamp, works like a charm.
  10. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    nope. Didn't work. Its getting worse and its so frustrating.

    How can I raise awareness of this happening as Apple need to know its still doing it in 10.8.2. Its making my iMac unusable. It's a waste of time me taking it in to the apple store as I know full well it wont even do it there as I cant get it to do it on the other router I have. Even though this router works fine with everything else and worked perfectly up until 10.8.2:(
  11. yoseeep macrumors newbie

    Sep 24, 2012
    i had the same issue since 10.8.2 . thank you 100times, this fixed it! :apple:
  12. SyncFx macrumors member

    Feb 27, 2011
    Vancouver, BC
    You can try adding a new Location in the Network Preferences.

    Top Center it should say Locations: Automatic. Click it and select Edit Locations. Add a new location and name it. Save it. You can delete the Automatic location, but I think that removes all your saved networks such as WiFi.

    Everything will be "fresh" in a sense.
  13. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    tried that as well with no luck. Its becoming really frustrating. I went to post on the apple support forum but the log in process was being ridiculous, saying I needed to create a username when logged in with my apple ID and then saying my email already has a username:/
  14. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    Im currently having a play but I'm starting to suspect that the problem links to trying to sync a device wirelessly with iTunes. Seems to drop whenever this happens (I have an iPhone and an iPad 3).

    Anyone else noticed this pattern?
  15. jsmiley125 macrumors newbie

    Sep 27, 2012
    Columbus, OH
    Yes! I am seeing this exact same problem since upgrading to 10.8.2. It *seems* to only happen when I have iTunes running and I try to sync my iPhone.

    Not sure if it's related, but I've been having trouble getting iTunes to consistently see my iPad over Wi-Fi sync as well.

    I'm thinking about ripping out iTunes and reinstalling it. And/or reinstalling the 10.8.2 update using Apple's combo updater.

    If either works, I'll post here.
  16. blatopilot macrumors regular

    Sep 24, 2011
    Try turning off your hardware (mac, phone, ipad etc) and then unplugging your modem and router for 2-3 minutes.

    Plug modem in first, router second, then power on hardware.

    Also it might be helpful to create a new location in network preferences. Create a new one, delete the old one and see how that works.
  17. NewJorg macrumors newbie

    Aug 19, 2008
    I found this solution elsewhere on MacRumors (by an apparent genius named troutspinner) and it WORKED:

    "I believe I've proven my theory correct and have fixed it.

    For starters, I've read many posts on the internet about resetting pram, deleting your network location, re-establishing you network etc. but after trying them, never once was I prompted to enter the password for my network. This tells me that my network password and configuration was stored somewhere.

    That somewhere was keychain. Go to your Spotlight (magnifying glass in the upper right hand corner) and type keychain and you will see "Keychain Access". Click on it to enter Keychain Access.

    In Keychain Access I noticed duplicate entries of my network in both system and login. Click on Login, then sort by Kind and you will see "Airport network password" for every network you belong to. Now delete the one you are having issues with as well if there are duplicate entries. If there are, this is most likely your problem. Now click on System and delete the one you are having issues with as well if there are duplicates. Once again, if there are, this is most likely your problem.

    Close Keychain Access and click your WiFi Icon in the upper right hand corner and then click on the network you want to connect to. It should prompt you for a password, fill it in and then click on remember. Viola! Fixed!

    I've made it sleep, I've shut down completely and now it just works.....like I am used to.

    Let me know how you make out. Just because this fixed it for me does not mean it will work for everyone as our problems could be very different."
  18. I'm a ROb macrumors member

    Aug 14, 2007
    What worked for me...

    I had the same issue when upgrading to Mountain Lion. I too tried making a new location, switching to MTU=1453, resetting the PRAM, deleted the keychain items but all were not of much help. My internet speed kept on being something like 5 to 10 times slower than before.

    I tried playing around with the settings of the wifi. I already tried switching to a specific band (instead of auto), but I found not much improvement. Until I decided to try all bands and I found one that brings it back up to speed. It could still be better, but I'm satisfied for now.
  19. tommy060289 thread starter macrumors regular

    Jun 20, 2011
    I've tried backing up the computer and installing fresh mountain lion and then updating before restoring from time machine and post update, pre-restore the wireless seems to work but then after restoring the problems seem to appear again so I think I am going to try starting a fresh. Just need to figure out what I need to save files wise to put on new machine.
  20. Tech198 macrumors G5

    Mar 21, 2011
    Australia, Perth
    Theres a Wi-Fi issue ?? :eek:

    Been using Wi-Fi all the time here, and no problem with 10.8.2.

    Of course i didn't upgrade.... I re-downloaded 10.8.2 from the App store, backup-ed up & and did fresh instal from newly created 10.8.2 usb stick.

    This is why i don't like upgrading..... (although i do it, at least i know to expect issues with anything).

    But if there are no issues, touch wood :)
  21. fisherking macrumors 603


    Jul 16, 2010
    ny somewhere
    i have a dual-band router; i have all kinds of issues using the 5ghz band (my GF, on an older mbp, has NO problems).

    using the 2.4 band solved the problem completely (or rather, is a workaround...i cannot figure out the issue with the 5Ghz network)...
  22. Tech198 macrumors G5

    Mar 21, 2011
    Australia, Perth

    Try a different channel usually help.. Probably not that common on 5Ghz, but wouldn't hurt to see anyway.
  23. jjmania macrumors newbie

    Nov 26, 2012
    Awesome! It worked!

    Thank you sooooo much! This is the only thing that seemed to work, at least so far! I have been going crazy for days having to boot my computer continuously just to get the connection, even though it said I was connected. Hope this continues!:D
  24. s.hackler macrumors newbie

    Dec 16, 2012
    I've tried every suggestion!

    I've tried everything y'all have suggested and it's still not working.
    My Computer:
    -MacBook Pro
    -13-inch, Late 2011
    -Processor 2.8 GHz Intel Core i7
    -Memory 8 GB 1333 MHz DDR3
    -Graphics Intel HD Graphics 3000 512 MB
    -Software OS X 10.8.2

    I got it in June of 2012 (I've had a MacBook since 2008) and everything worked fine on it. Well, when I moved to a different house like 5 miles away, I set up my wireless (same service provider, same router, same login and same password) and it worked fine. When I got roommates I decided to change my password and login information to something we could all remember fairly easily and because everyone around us had crazy names. On of my roommates has white Macbook from 2007/2008 and she used my wifi all the time before she moved in and everything switched over fine for her when we changed the information. Mine however will lose the signal if I close my laptop or if I let it sit for too long which is quite an inconvenience. My other roommate has no problems staying connected to the internet but she has a windows computer. :rolleyes:
    I can go over to my friends houses and my computer picks up their wifi immediately and it never loses it. I don't even have to select their wifi, its just automatically connects when I open safari.

    So for some reason my computer, and my computer alone, only hates my WIFI network. I've completely deleted every wifi network from my computer and I've started over like one of the posts suggests. I turned my MTU down to 1400. I'm desperate to get this fixed. I've been kicked out of my online homework and online quizzes. Thankfully my teachers were understanding the first time but having to go up to my school library (which closes at 11PM, crazy right?!) to do my work is a pain in the butt especially when my parents spent over $1300 on a laptop for me to do my work at home :mad: :mad:

    Even though I've had a macbook since 2008 and I'm a total Apple fanboy I still haven't learned all the ends and outs of my computer so if anyone has any suggestions please please please help. I've put in a service request call but I won't be able to hear from them for a couple of days between my school/work schedule and their openings. If they help me out before someone replies I'll post what they did here.

    Thanks in advance!! :D

    ETA: My internet speed works fine
  25. Goldenarmz97 macrumors newbie

    Aug 19, 2011
    Every device other than my Mac connects fine. I'm PO'ed.

Share This Page